2

I have a Canon PIXMA MX700 connected by ethernet. When I first bought it I was using OS X 10.4, and scanner-initiated scanning worked fine. After upgrading to 10.6, neither scanner-initiated or scanning from MP Navigator EX works with the firewall enabled. The firewall lists exceptions for three applications:

  • Canon IJ Network Scan Utility.app
  • Canon IJ Network Scanner Selector.app
  • MP Navigator EX 1.0.app

I get no further blocked warnings, and /var/log/appfirewall.log lists nothing for today (my latest attempt to use it).

1

Try opening TCP port 5100 (scanner and camera sharing) and TCP port 49201 (I discovered that there is a lot of traffic on this port when scanning with firewall turned off). You can enable the passive FTP range in firewall settings (at least on the Snow Leopard Server)

1
  • Alas, I'm on a laptop, I can only select applications, not ports. Apr 12 '11 at 17:04
0

I don't have my OSX machine handy, but the issue isn't with the applications. If the scanning is initiated at the scanner, than the firewall is blocking the incoming stream (that is, from the scanner to the computer). I believe that instead you need to setup the firewall to allow incoming data over specific ports.

2
  • Is that possible in the GUI, or do I have to drop down to command line/config file? Dec 1 '09 at 21:06
  • @Adam, the Mac OS X built-in firewall is an application firewall, not a port-based firewall.
    – Arjan
    Apr 3 '10 at 11:18
0

I was having the same problem with a Canon PIXMA MG5200. Every time I tried to scan from the button on the scanner it would prompt me to Allow either 'Canon IJ Network Scanner Selector.app' or 'MP Navigator EX 4.0.app' to accept incoming connections. I checked the advanced firewall settings and both apps were already listed to allow incoming connections. I tried removing and re-adding them but to no avail.

Eventually I used Disk Utility to 'Repair Disk Permissions' on my system drive. It went through and changed permissions/ownership on a number of the Canon utility's files. I then rebooted and since then it has been working fine - no more prompts.

Give that a try and see how you go.

0

just happened across this - dunno if it helps but does list the tools you did and the ports related to them.

http://kbsupport.cusa.canon.com/system/selfservice.controller?CONFIGURATION=1011&PARTITION_ID=1&TIMEZONE_OFFSET&CMD=VIEW_ARTICLE&ARTICLE_ID=34549

It specifically lists ports 8611-8613 for tcp and udp plus some other ports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.