I have recently upgraded from Windows 7 to Windows 8.1 on one of my home workstations. I have another machine running Ubuntu 13.10.

Prior to the update to windows 8.1 I was able to access the shares on Ubuntu (shared by right clicking on the folder -> Sharing Options), and currently other devices in the house can still access the shares (these are another Windows 7 device, Android devices, and even an old Windows XP device). All other devices I have can still access the shares. These shares have all been configured to Allow others to create and delete files in this folder and Guest access.

It's just this Windows 8.1 machine that while I can see the shared folders, trying to open one of them results in a Windows Network error message you do not have permissions to access...

I would think that since these are shared with Guest access, there should be no possible permissions that are getting in the way, and for the other devices i have, this seems to be true.

Also, all the folders involved in shares have permissions 777 applied through chmod. For this problem I've also found Nautilus right click permissions setting Create and delete files for all groups.

I've found articles around that talk about updating HKLM/System/Services/LanmanServer/Parameters/RequireSecuritySignature to 0 (which was already set to 0, BTW).

It seems silly that I should need to change my smb.conf file as ALL other machines access this share perfectly well, although I've found some that say Wins Support should be Yes and others that say it should be No. I've tried this with no change. The same error message about security still appears.

One thing that I'm sure of, is that Windows 8 made me use an email address and the login information from that address to be able to log into this system. Again though, the shares are set to allow guest access.

Below if the contents of smb.conf in case it helps.

#======================= Global Settings =======================
    workgroup = WORKGROUP
    server string = %h server (Samba, Ubuntu)
    wins support = yes
;   wins server = w.x.y.z
    dns proxy = no
    name resolve order = wins lmhosts host bcast
;   interfaces = eth0
;   bind interfaces only = yes
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    encrypt passwords = true
;    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    map to guest = bad user
;   domain logons = yes
;   logon path = \\%N\profiles\%U
;   logon drive = H:
;   logon script = logon.cmd
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u
; add group script = /usr/sbin/addgroup --force-badname %g
;   printing = bsd
;   printcap name = /etc/printcap
;    printing = cups
;   printcap name = cups
;   include = /home/samba/etc/smb.conf.%m
;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash
;   winbind enum groups = yes
;   winbind enum users = yes
;    usershare max shares = 100
    usershare allow guests = yes
#======================= Share Definitions =======================
;   comment = Home Directories
;   browseable = no
;   read only = yes
;   create mask = 0700
;   directory mask = 0700
;   valid users = %S
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700
    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
;    guest ok = no
;    read only = yes
    create mask = 0700
    comment = Printer Drivers
    path = /var/lib/samba/printers
;    browseable = yes
;    read only = yes
;    guest ok = no
;   write list = root, @lpadmin
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes
#    cdrom share is accesed. For this to work /etc/fstab must contain
#    an entry like this:
#    is mounted on /cdrom
;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom
    path = /media/jeff/Storage/DROP
    writeable = yes
;    browseable = yes
    guest ok = yes
  • Try mapping that fileshare as a drive instead directly accessing as a UNC path. Also, try mapping it as a drive and choose the "Map folder as another user" option in Windows. Use some username/password from the Ubuntu OS that has explicit permission for that share, maybe even the share/folder owner. May not be your long term fix, but might provide some insight.
    – jimtut
    Jun 9, 2014 at 1:44
  • 1
    @jimtut, thanks for the suggestion. it's interesting that while i was unable to make this work through the UI (windows would complain that this drive was already mapped with another user), instead net use mapping this drive with another user worked.
    – Beta033
    Jun 9, 2014 at 18:48
  • 1
    Glad you figured it out. You can submit the 'net use' item as an answer, and then Accept it to close out the question, if you're happy with your own solution/workaround.
    – jimtut
    Jun 9, 2014 at 22:46
  • while it works and is a good temporary fix for this one workstation, i don't really see it as a real solution. i shouldn't have to hack workstations to get ubuntu and windows 8 to talk together. I think i'm going to let it ride a little bit in hopes that someone may shed some light on why it doesn't work and what to change for this to actually work the way it should.
    – Beta033
    Jun 10, 2014 at 2:17
  • can you please post the net use solution @Beta033
    – Pete
    Aug 20, 2014 at 14:30

4 Answers 4


It's clear that it is a problem with the local security policy on the Windows 8 OS client machine.

In our enterprise we started by using our old GPO (the one we use for Windows 7 machines) for our Windows 8 machines. This instantly fixed it, but our security department weren't happy and didn't allow us to roll it out to all Windows 8 machines, so then we started cutting away at our policy and the deciding factor for us was the following setting:

In "control panel" go to "administrative tools" open "local security policy", then "local policies" -> "security options"

Microsoft network client: Digitally sign communications (always) - Set to Disabled Microsoft network client: Digitally sign communications (if server agrees) - Set to Enabled

This fixed it for us, but if it doesn't help for you try opening up other restrictions in "local security policy" for the client machine and test your connection to the Samba shares.

Good luck, I hope I help someone:)

  • 3
    too conversational, try being more objective in answering and stick to the point. Aug 20, 2015 at 12:28

It's much easier than what you think (or I am missing something?). On the Windows 8.1 PC I did:

  1. Control Panel -> Administrative Tools -> Local Security Policy.

  2. Enable - Microsoft Network Client: send unencrypted password to third party SMB servers.

  3. When asked for credentials in user name type: servername\userame. Do not just type the username only.


Here's how to enable SMBv2 and SMBv3:


You want to run those commands in an elevated command-prompt to enable SMBv3:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

This might help too:

Set-NetConnectionProfile -interfacealias Ethernet -NetworkCategory Public
Set-NetConnectionProfile -interfacealias Ethernet -NetworkCategory Private

You cannot access your share, because Windows 8.1 share uses SMB 3.02 version, which is not yet supported by FreeNAS.

Fix: You can edit your share's preferences in fields min and max value of SMB versions try to choose accordingly SMB 2 in min and SMB 3.00 in max version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.