1

I've recently repaired my ancient G4 Mac Mini, I have reinstalled Tiger and applied all updates. I have Synergy setup between the PC and the Mac, with the PC being the server and the Mac being the client. They show in the log as being connected properly, and when I mouse to the Mac's screen the log shows that it switched screens, and the clipboard gets updated properly as well - but no matter what I try the Mac's mouse will not move. I have tried various versions that support 10.4 and of course the matching version on the PC each time (even 32-bit), the configuration all shows that it's working fine but the Mac mouse does not move. I also tried enabling "access for assistive devices" in System Preferences, as I saw somewhere that that solved someones problem but it made no change for me. Also Scroll Lock doesn't seem to be the issue because, if I lock it to one screen or the other after the log says it's crossed over, it locks like you'd expect - but the Mac's mouse does not move. What can I do? I had this working fine years ago before this Mac failed between it and an XP pc. Thanks for any help, I don't have the desk space for 2 sets of mice and keyboards, especially not with my midi keyboard I wanted to use with GarageBand, and the Mac only has 2 USB ports, and I have no hub. Synergy 1.4.8 is the latest version supporting 10.4 so that's what I've been trying.

Thanks for any help, this is really baffling, it all says it's working but the mouse does not move.

INFO: switch from "Kassandra-PC" to "MacMini" at 1679,595 INFO: leaving screen INFO: switch from "MacMini" to "Kassandra-PC" at -1676,280 INFO: entering screen

1

I've had the EXACT same problem you described for several months and just fixed it!

I use a 64 bit Dell PC as my primary computer and host/server, running Synergy's x86 (32bit) version 1.5.0. (In troubleshooting, I replaced the 64 bit version with the x86 version. Both the 64 and 32 bit versions would connect with the Synergy client on my old PC running XP, so I didn't bother changing back to the x64 version.)

The Mac/client operating system is 10.4.11. Synergy version 1.4.8 used to work with the PC running XP; however, it wouldn't work after I started using the 64 bit Dell as the server. Also, when I tried going back to using the XP PC as the server again, it had the same problem. Based on that, I assumed that there was some problem on the Mac.

None of the old or new Mac versions on Synergy's website worked. I found a really old version called SynergyKM, ver. 1.3.0 (copywright from 2002!) on another old Mac and it worked. NOTE: Before installing it I used Finder to search for all old synergy files and deleted them - this was probably a key step!

I don't know where the old version that worked for me can be located online. It's one of the GUI versions that came as a .dmg file - not like the pre 1.4.5 versions on Synergy's site that come in .zip files. If you'd like me to send it, send an email (my name shown on this post at gmail.com).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.