0

I'm trying to have my HD run in AHCI mode with Intel RST drivers (not just mshahci.sys) after installing windows 7 in IDE mode.

Specs: Windows 7 x64 SP1, Asus Maximus III Gene, ASUS AMI bios Rev. 2202, Western Digital WD5001AALS-00E3A0.

At first, booting in AHCI mode failed with BSOD's (error: 0x7B). I found this tweak and after applying it I was able to boot in AHCI mode with default AHCI windows drivers (msahci). Then, while running windows in AHCI mode, I installed Intel RST version 12.9.0.1001 but the BSOD's returned even though I previously applied that register tweak. Booting in IDE mode still works. So with no other option but to boot in IDE mode I uninstalled the RST drivers but it only removed the app, not the drivers. When I try to boot up in AHCI mode windows is still trying to use the RST drivers (resulting in a BSOD) instead of the default msahci driver.

Reapplying the register tweak, hoping that it would somehow set msahci as the default driver, doesn't work. The biggest problem right now is that windows can't recognize the HD controller as an AHCI controller because I'm forced to boot in IDE mode. So there is no (regular) way for me to change the AHCI driver windows should use. I probably did not properly deinstall Intel's drivers which might be causing the problems.

Question: Does anyone know how to specify that windows should use msahci instead of the RST AHCI driver (iaStorA) while running in IDE mode.

Edit: I changed my wording to be a bit more clear about what my actual question is.

0

I solved the problem using the solution in this question:

"OK. It seems to have booted succesfully now. Booting in safe mode I uninstalled the Intel drivers, then rebooted safe again and removed all system devices related to ICH8 in device manager, Rebooted in IDE mode to safe boot and allowed Windows to detect the IDE devices, then rebooted again and in safe mode with device set to AHCI allowed Windows to detect them again. A regular boot then worked. Successive reboots have been clean also :)"

I posting this with my controller in AHCI mode. It even uses the most up-to-date Intel RST driver (12.9) instead of msachi :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.