For the past week or so I've been having an issue with the Hangouts system tray icon hiding itself. Normally I have it show all the time so I can easily click it, but it seems no matter what I do, within a day or so it's hiding again. When it hides, I click "Customize" in the system tray and select "Show icon and notifications" for both instances of Hangouts that show up in the list. However, after a day or so it seems to always revert one of them to "Only show notification" as shown in the attached screenshot. Changing it back fixes the problem, but only temporarily.

How can I get Hangouts to always show in the system tray?

EDIT: Looks like it may not be just Hangouts. Just had Battle.net do the same thing.

System Tray Customization

  • 2
    I've got the same thing suddenly happening here, so it's likely a bug. – alexleonard Jun 11 '14 at 9:11
  • 3
    @Ryan This happens to me pretty frequently as well. For me it has to do with hangouts constantly updating. When it's the same version the hangouts still shows. However when the extension updates it hides. I'm not sure how to fix that. – meguroyama Jul 7 '14 at 9:37
  • 2
    @BenFranchuk Ya, I am using Windows 8. I do get the feeling it's just a system bug. – Ryan Aug 5 '14 at 11:29
  • 1
    I agree with @meguroyama. I believe it has to do with constant self updates. Hangouts being kind of a web app, sometimes suffer small updates many times a day. Windows probably stores info by app version and looses that when it updates. – Natan Aug 28 '14 at 14:37
  • 1
    @harrymc As mentioned in the EDIT at the bottom of the question, it appears to be any updated application. When Battle.net (Blizzard's game client) is updated, that moves from visible to hidden in the tray as well. It's easier to see the effects with Hangouts because it is frequently updated. – Ryan Oct 8 '14 at 13:42

After extensive playing around with different settings, I was never able to get anything to work. It seems that any application that is updated is automatically relegated to the hidden part of the system tray, regardless of the old settings for the application.

However, Google released a Chrome app for Hangouts (as opposed to the old extension) that removes it from the system tray entirely. Using the app, Hangouts now has a proper Taskbar icon, and behaves more like a native extension. I know it doesn't exactly fix the original issue, but it removed the issue entirely for me.


Apparently there can be 2 issues.

The first one is a priviledge error. Shameless copy pasting:

Program Files (x86)\Google\Chrome\Application > right click chrome.exe > Properties > Compatibility > Change settings for all users > and tick "Run this program as an administrator"

Or this can be a profile error, can you try it with a different profile?

Hope this helps.

  • Well, I'm not willing to let Chrome run as an administrator just to fix this, but I've given the profile trick a try. We'll give it a few days and see what happens. – Ryan Aug 28 '14 at 1:14
  • Well maybe you just need to run it one time as admin to let itself configure properly. Good luck. – bemug Aug 28 '14 at 14:14
  • Well, the profile trick seems to have made no difference. It's too bad, too, because I had high hopes. – Ryan Aug 28 '14 at 15:38

Icons show up in the system tray when an application is turned on or it makes a notification.

Make sure that the Task Bar has enough room to hold all your applications. The System may decide to filter your system tray if there's not enough space.

Setting your Task Bar to default options : Icon size and others may resolve your issues.

Notifications are generally generated by the System. If an application can hijack your system tray by making huge pop ups, update notification that slow your computer and other similar actions, you should remove it.

A few programs have their own system notifications like steam and Skype. Changing the Notification Settings in the Icon Tray have no effect.

  • 1
    As you can see from the question, it is not a problem with notifications, or space in the system tray, but a matter of applications setting themselves to "Only show notifications" when I want them to "Show icon and notifications" – Ryan Aug 11 '14 at 14:50

It looks like this problem is caused by the installer of Hangouts and cannot be fixed except by repeatedly resetting the notifications data after every update of Hangouts.

You could of course complain about it in the right forums, but in the meantime I found a couple of programs that may be used as a workaround, as detailed below.

A C-program can be downloaded from the article New Windows Tray / Notification Manager is here.

The advantage of this program is that it has both GUI and command-line capabilities. Calling the program without parameters will display all the tray programs and their names (which are not always that easy to figure out). The command-line can be used to reset the the notifications for a program (warning: I don't use Chrome so its name below is just a place-holder) :

TrayManager.exe -t "Chrome's name" 2

As the tray icon data is read by Explorer when Windows starts and stays in memory, the above changes might seem to have no effect. One needs to restart Explorer, for example by a batch (.bat) file such as :

taskkill /f /im explorer.exe
"<path-to-program>TrayManager.exe" -t "Chrome's name" 2
start explorer.exe

To ensure that this is always done when logging to Windows, you can set this script as a Logon script. Doing that is described in the article Forcing notification area Icons to always show in Windows 7 or Windows 8, which also contains an alternative to the above TrayManager program in the form of a PowerShell script, in case TrayManager does not work for you.


I had a similar problem with the hangouts system tray icon working for a while but gone shortly after. Turns out it was because I did not have a windows password.


I had a similar problem with Google Hangouts notification icon randomly disappearing. If you look at your screen shot, there are 2 instances of Google Hangouts, which I believe are conflicting with one another. All icons are cached in the Windows Registry, so you'll need to perform a little regedit black magic.

  1. Press [Windows R], type [regedit] and hit [enter].
  2. Confirm the UAC prompt if it is displayed.
  3. Navigate to the Registry key HKeyCurrentUser \Software \Classes \LocalSettings \Software \Microsoft \Windows \CurrentVersion \TrayNotify
  4. Make a backup of the Registry key by right-clicking on TrayNotify and selecting Export.
  5. Now delete the following two Registry keys: IconStreams and PastIconsStream
  6. Open the Windows Task Manager with [Ctrl Shift Esc]
  7. Terminate the explorer.exe process
  8. Click on File > New Task Run and enter explorer.exe to reload the explorer process

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.