1

I have a Kingston 4GB Datatraveller USB flash drive that has seemingly become corrupted. On my main computer, the drive continually connects and disconnects and shows up as an Unknown Device. On my laptop however, the drive connects successfully, but is unusable. In CMD, using Diskpart, the drive appears to be in a RAW file format.

Diskpart spouts errors when attempting to format the drive, and the other dozen different programs from the threads I've visited (both from Google and from Superuser) to try and make this flash drive usable again produced no results. I've also tried PartingMagic, gParted, and Knoppix to try and format the drive, but they weren't able to see the flash drive.

Even stranger, the drive appears as a 'SKYMEDI USB Drive' in Device Manager when, previously, it showed up under the correct name, 'Kingston USB 2.0 Datatraveller'.

I have no qualms about losing the data on this drive, I simply want to make it usable again. I've spent about a week trying to revive this flash drive and I believe I've exhausted all the options I am aware of. Does anyone out there possess any other solutions for this matter?

For reference, below are the programs I've used:

  • GetDataBack
  • Testdisk
  • HD Low Level Formatter
  • EaseUS Partition Recovery
  • MediaREC
  • SDFormatter
  • HP USB Disk Storage Formatter
  • Super Stick Recovery Tool
  • Repair v2.9.1.1
  • Kingston Format Utility
  • SK6211_20090227_BA
  • JetFlash OnlineRecovery
  • Repartition Tool
  • My opinion: the media has become defective, the embedded controller cannot get anything useful from it anymore. A dustbin is the place to be. – LatinSuD Jun 10 '14 at 18:54
  • Agreed with @LatinSuD, I'd RMA if it's still under warranty. I assume you've tried on other computer as well? If so, it looks like a hardware problem to me. – chmod Nov 19 '14 at 6:50
  • I had a somewhat similar issue as you OP and the drive ended up being used as a doorstop. Eventually things just die. – bcm27 Apr 5 '17 at 2:26
2

iFlash is a collection of pendrive recovery tools. If you could find your model there, you'll find out what tool could be used to fix it. Those tools are very low-level and have to be dedicated for specific pendrive, even tool version matters.

The procedure usually goes like this: first, you have to find product and vendor identifier of your flash drive (PID and VID). One of those has probably been changed (that's why it shows under different name), but iFlash has them listed. To fix the drive, you have to run a program included with your downloaded tool that will let you install alternative drivers for that flash drive. After installing them, it will stop reporting as a flash drive and will enter low-level settings mode.

At this stage you'll want to erase entire memory, so you can repartition it correctly later. Then you should restore original PID and VID. After reconnecting, flash drive should appear and it should be possible to format it. If it won't work, the drive is permanently damaged.

Be careful when using those tools, features they offer are quite advanced and you can make things even worse. Remember that not all drives can be fixed, actually chances are quite low. 4 GB pendrives are pretty cheap, messing with low-level tools may not be worth it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.