3

I installed Apache on Windows 7 (localhost) and it worked fine. Then I went to download some other stuff and later noticed that the Apache server stopped. I went to command prompt (as administrator) and typed

net start apache2

It says "The Apache2 service is starting." But before it finishes, I get the error

A service specific error occurred: 1.

It says that you can type in "NET HELPMSG 3547" for more info, but that doesn't help at all.

Things I have tried:

  1. Quit Google Drive Sync
  2. Quit any and all programs using port 80 (port my server is on)
  3. Tried changing the port of the server and got same error message, so I don't think it has anything to do with something else being in the port

None of those things have worked. I am confused at why it worked earlier, but now it won't work.

  • I'm not the one to judge you, but why don't you use nginx instead? – arielnmz Jun 11 '14 at 8:55
  • I am using it with coldfusion and it is integrated with apache. – user2297366 Jun 12 '14 at 15:13
4

You should check the Event Viewer for whatever shows up in the Windows Logs. Under the Application section there should be a list of errors with more details about what was exactly going wrong.

Recent example found:

The Apache service named reported the following error:
>>> Syntax error on line 523 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf:

In the above example it was because a referenced drive was no longer on the system and Apache could not find it.

You can usually (at least in Windows Vista) find Event Viewer along the lines of:

Control Panel → Administrative Tools → Event Viewer

This should highlight any thing touching the system that you may have overlooked and provide further details and hints about what to tweak or change instead of just uninstalling everything.

  • What versions of Apache have been packaged in such a way that they write to the Windows event logs? I used bitnami's apache httpd and I'm pretty sure it doesn't write to the windows event logs. I could be wrong as I haven't installed the latest bitnami versions in the last few months. – Warren P Dec 19 '15 at 18:15
  • Don't remember, set it up that way years ago from the one that's apache_2.2.8-win32-x86-openssl – random Dec 19 '15 at 18:22
0

Apache server wouldn't start after I downloaded coldfusion and added it to the server. I just uninstalled apache and coldfusion and reinstalled apache and it works fine now. The official error was that I added an extension(coldfusion) to apache and for some reason apache didn't recognize it.

  • Did you use the logs to figure that out? Usually the most general answer is "when the service fails to start, go look at the logs". For apache, it won't be in the Windows logs, so look on disk for the text logs produced by Apache httpd. – Warren P Dec 19 '15 at 18:12

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.