Does anybody know how to re-enable your own extensions after they were disabled by the Chrome v35 update?
(Mostly greasemonkey scripts in my case, thus simple .js files previously drag-n-dropped in to the extension windows. )

When I started up Chrome today I got the warning that some non-ChromeWebStore extensions were disabled.

More info was giving on this link:

Extensions disabled by Chrome

You're seeing this notification because one or more of your Chrome extensions has been turned off to make Chrome safer. The extensions didn't come from the Chrome Web Store or were installed without your permission.

For your protection, you can only use Chrome extensions that you get from the Chrome Web Store.

To see a list of your extensions:

  1. Click the Chrome menu Chrome menu on the browser toolbar.
  2. Select Tools.
  3. Select Extensions.

Extensions that have been disabled are grayed out and you won't be able to re-enable them.

I was hoping I could still enable them by activating developer mode for my extensions but still no luck.. Any tips anyone?

P.s. this is not a duplicate from Activating a Chrome extension that is not from the Chrome Web Store as this is related to the chrome v35 update

  • 7
    Short story: you can't since google wants users to use their web store, so they can track them, they can show 9999999 ads, etc... It's about making money, not user experience. Imho. it's better to forget that browser for eternity.
    – inf3rno
    Jun 20, 2015 at 20:47
  • It's unfortunate because I use to turn to Google to avoid these issues. To Chrome's defense, even Firefox is deploying a similar constriction now - I suppose one could argue the gained "safety" aspect of this rule enforcement. Aug 4, 2017 at 13:40
  • @inf3rno that's beyond impractical... do you also abandon your citizenship if your country published a minor law you disagree with? Jan 12, 2021 at 17:55
  • @AlexanderK. It is a very bad analogy and one can use a different browser, e.g. Firefox instead. Maybe it is possible with Ungoogled Chromium too, I haven't checked.
    – inf3rno
    Jan 12, 2021 at 20:35
  • @inf3rno in that case, you should have offered alternatives instead of jumping on conspiracy bandwagon about "evil" Google Jan 13, 2021 at 0:01

7 Answers 7


There are really only a couple of options open to you as the ability to run the extensions has been programatically disabled with no plans to re-enable it (or at least none made public)

You can try installing from the canary channel or the developer channel releases which may allow you to still run these extensions as mentioned in Google Chrome help forum:

What if I want to run non-web store extensions?

Advanced users can continue to use our Dev & Canary channels to run any extension. Please note that these channels are updated very regularly, and may contain features and bug fixes that are actively being developed.

Alternatively, I have heard that quite a few people install Tampermonkey which then allows the running of user scripts.

Might be worth a look.

  • 4
    Thanks. Tampermonkey was indeed the way to go for my use-case (manually added userscripts). I couldn't just re-enable it with tampermonkey though. I really had to find the .js file in %localappdata%\Google\Chrome\User Data\Default\Extensions and copy-paste the contents
    – AardVark71
    Jun 11, 2014 at 12:00
  • 3
    I got TamperMonkey to work with my script by going to TamperMonkey Settings, and clicking the "New Script" tab (leftmost tab), and pasting the text of the script into the editor there. When I clicked the save button, my extension started working again. Thanks for the help! Jun 11, 2014 at 23:15
  • Am I the only one who was able to get userscripts to work by packing them into crx files and dragging them into the Extensions page.
    – Shazvi
    Jun 12, 2014 at 9:44
  • My extensions were in a "Profile 1" folder, not a "Default" folder. %localappdata%\Google\Chrome\User Data\Profile 1\Extensions
    – Matthias
    Jun 13, 2014 at 17:48
  • 5
    Just FYI, Google just pulled this functionality from Canary and Dev, you have to use the method in the below answer, or load as a script through tampermonkey / similar. Source: blog.chromium.org/2015/05/…
    – Arthur Kay
    May 15, 2015 at 2:52

You can't re-enable them. You need to workaround this issue using any of these alternatives (I will list them for grade of difficulty):

Install other Chromium-like browser

Since Chromium is opensource, there are several forks of the project. I'm not sure if Chromium has the restriction in place but other project may not.

Moving from Windows/OSX altogether

This restriction is put in place for Windows and OSX due security concerns of the entire OS. Linux builds are not affected. You could give any Linux distribution a try.

  • 1
    I am a little perplexed, 4 machines running 35.0.1916.153 m (standard non-Dev/Canary) and 2 of the machines do not disable the extensions with developer mode enabled, added by dragging the crx file (& not unpacking first), but the other 2 continue to disable them on re-launch. I have even tried the master_preferences and again only of the two computers does it disable on re-launch.
    – codemonkee
    Jun 15, 2014 at 19:07
  • @Spero.ShiroPetto give it time... it will reach you, maybe in 36.0.
    – Braiam
    Jun 15, 2014 at 19:22
  • @Braiam: +1 good answer, you should add the option of using Tampermonkey extension to manage all userscripts.
    – Amro
    Jun 16, 2014 at 18:59
  • @Amro my answer is oriented to real extensions (those that comes in the .crx way)
    – Braiam
    Jun 16, 2014 at 21:45
  • 2
    Right, I'm referring to the section below that saying Canary and Dev are not prevented from installing non-store extensions is no longer valid. Google juuuust took that away.
    – Arthur Kay
    May 15, 2015 at 2:54

There's another option (at least on Mac) -- there's Google's own Chrome Apps & Extensions Developer Tool (https://chrome.google.com/webstore/detail/chrome-apps-extensions-de/ohmmkhmmmpcnpikjeljgnaoabkaalbgc/details) which allows you to re-enable any extension installed.

  • 1
    @Braiam OSX seems to be affected as of Version 46.0.2490.86, and this fix worked. Nov 11, 2015 at 5:43
  • 10
    Not working on Windows in 47.0.2526.106 m. "Enable" mark becomes unchecked right after you check it
    – janot
    Jan 15, 2016 at 15:43
  • 4
    Worked for me on OSX. This answer need more upvotes! It sure beats switching to Linux, for god's sake.
    – thule
    Mar 10, 2016 at 14:07
  • 2
    Not working on OSX with chrome 52.0.2743.82
    – xi.lin
    Aug 2, 2016 at 2:28
  • 1
    Does not work for me Win 10 Chrome 75 (Official Build)
    – Ajay
    Jul 10, 2019 at 15:47

Both Chrome and Edge like to disable non-store extensions. On Windows, adding the extension IDs to the following registry keys has so far always reactivated them.

(Chrome switched from HKLM-SOFTWARE-Policies-Google-Chrome-ExtensionInstallWhitelist to HKLM-SOFTWARE-Policies-Google-Chrome-ExtensionInstallAllowlist, I have simply add both variants just in case).

I have 2 extensions that need activation, so I run a REG like this:

  • 1
    This worked for me with the Bypass Paywalls Clean extension on Chrome 120.0.6099.217 on Windows 11. Jan 11 at 20:53
  • 1
    Works for me +1. You can also see a guide here github.com/qnoum/bypass-paywalls-chrome-clean-magnolia1234/tree/… . Just create a .reg file on Windows, and copy the texts into it, modify the extensionid (which you can find from the extension page of Chrome/Edge), save it and run. Then it will add the path and entry in your registry. Restart the browser, and the extension will be turned on automatically.
    – Rick
    Apr 17 at 3:55
  1. Go to chrome://extensions/,
  2. Enable Developer Mode (top right)
  3. Click Load unpacked
  4. Select the directory containing the extension

Doesn’t work?

  1. Install Chrome Apps & Extensions Developer Tool
  2. Click Launch app from the store page
  3. Click Load unpacked...
  4. Select the directory containing the extension
  • With Google's latest change (101.0.4951.67), this is the easiest one to get extensions working again. Jun 6, 2022 at 14:36

I used the procedure exactly as described here in a Google forum. permalink


It basically involves moving, whitelisting the extension ID into the Group Policy Editor.

  • 3
    Doesn't work. After restarting chrome extensions are again disabled (Windows 7 Home Premium 64bit). Apparently this workaround doesn't stick for Windows Home editions.
    – DavidPostill
    Sep 11, 2014 at 17:06
  • This worked perfectly for me (Windows Vista 32bit).
    – Casper
    Feb 13, 2015 at 15:37
  • 3
    The whitelist procedure ExtensionInstallWhitelist works fine on computers participating in an AD domain. You do not have to actually set an administrative template policy, using the registry is okay. But it does not work on non-domain computers (this would include Home versions), I figure Chrome is ignoring policy for nonAD computers (sadly).
    – William
    Feb 2, 2016 at 14:12
  • Unfortunately this is not made to work on Mac Mar 28, 2021 at 9:27
  1. Add the --enable-easy-off-store-extension-install flag when you start chrome (create shortcut, edit target, append the flag).
  2. Navigate to chrome://extensions/ in the browser.
  3. Drag 'n drop the .crx to the browser, installing the extension.

You'll need to do it every time you launch the browser.

  • 4
    The --enable-easy-off-store-extension-install flag makes no difference on Chrome 36.0. The non-store extension I installed is still disabled.
    – EM0
    Aug 22, 2014 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .