1

Problem: When I connect to my pc at the office via RDP all the application windows I had previously carefully placed on either monitor 1 or 2 will be "scrambled". Either all applications show on monitor 1 and monitor 2 is empty, or they have switched 1 <-> 2.

Expected behaviour: When I connect I see all the application windows on exactly the same position and in the exact same size as I left them the night before.

I have the exact same monitors at home as I have at work: Primary 2560x1440, Secondary 900x1440.

Yesterday I tried switching the physical cables on the host machine hoping that the hardware order of the monitors was the difference. But this morning my secondary monitor was completely blank, not even the taskbar (which I had set to ONLY show on the secondary).

Somewhere there must be something to help Windows understand which physical monitor is which virtual RDP monitor is which RDP "server" monitor... Are there more options than switching the cables?

This one has been bothering me for a long long time now, I hope someone has a solution or workaround for me.

Edit I want to use both monitors, so I have checked the "Use all monitors" setting in the RDP client. For example I leave my mail and total commander on the right monitor, and visual studio and Firefox on the left monitor. When I connect to RDP I want to see those applications on the same positions and sizes.

0

When you RDP into a computer you're not actually looking at the same desktop/displays as when you're sitting at the console. A new virtual display (monitor) is created for RDP use, based on the client's configuration.

If you have an existing session you are taking over, it will adjust the desktop for that session to match the new display configuration. Since the new display configuration doesn't match the old one, Windows will usually just reset the icons and window locations to default to the primary monitor. Similar happens when un-plugging and hot-plugging additional monitors (like say, on a notebook).

If you want to see your actual desktop as it is when sitting in front of it, then use a different remote control package (like VNC) that uses a screen capture and scaling system of the actual console desktop.

Alternatively, if your monitors/resolutions are going to be similar, and you want to stick with RDP, then perhaps check for a desktop utility that will remember and can restore window and icon locations on command.

Some video adapter manufacturers (used to) include this in their utilities, and there's stand-alone utilities out there to do it (after a quick google - never tried this one personally).

  • I was hoping that by using the exact same hardware on both ends would help Windows in choosing the right settings for those virtual drivers. I guess not. I will give VNC a go, not sure if it will be fast enough on my current internet connection (will be upgraded this year). I will post back my findings. – Martijn Kooij Jun 12 '14 at 7:45
  • Aside from being slow as expected, both TightVNC as wel as RealVNC do not support my landscape + portrait monitor setup... My seconday screen is in portrait but both viewers render the contents flipped 90 degrees... So that's a nope. – Martijn Kooij Jun 12 '14 at 18:39
  • Yeah, you're kind of stuck in a hard place. So I'd say you may be limited to looking into a window/icon location save/restore utility as I mentioned at the end of the answer. A bit of a pain, but you should be able to configure it to save/restore via a couple hotkey shortcuts. Hit a key-combo to save the positions before you leave one location, and then hit another key-combo to restore them when you connect form the new location. – Ƭᴇcʜιᴇ007 Jun 12 '14 at 18:44
  • I think it's a bit bigger that just window sizes/positions. It is almost as if my secondary monitor is not being recognized initially. Currently when I log in everything is only on the primary, even the taskbar (which I only have on my secondary). I think it's something like the initial connection only asumes 1 virtual monitor, and not until after connecting it detects and initialises the secondary... – Martijn Kooij Jun 17 '14 at 18:41
0

Im using different RDP parameters. Just save a RDP connection to the desktop and then open it with the editor. There are a lot of differnt setting you can make.

You are as well able to add new setting like smart sizing:i: . This setting determines whether or not the client computer can scale the content on the remote computer to fit the window size of the client computer. ( see http://technet.microsoft.com/de-de/library/ff393693%28v=ws.10%29.aspx). I use this on my Notebook because it is only able to display smal resolotions.

There are a lot more interesstion parameters. May be you will find your solution there.

See http://technet.microsoft.com/de-de/library/ff393699%28v=ws.10%29.aspx

  • I will try and disable the smart sizing setting and let you know the results. – Martijn Kooij Jun 12 '14 at 7:46
  • Late reply, it's kind of difficult to test (and the world cup...). But no, smart sizing changes nothing. I can see what the setting does, but it does not solve this problem. – Martijn Kooij Jun 17 '14 at 18:38
  • Thats sad. I will look into it. – Ivan Viktorovic Jun 18 '14 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.