I naively installed a driver update incoming from Windows Updates yesterday. That caused my Wifi on my Notebook (HP ELitebook 2740p) to break. The network is working as I tried it with my other mobile devices.

When installing said driver, it told me that the installation failed. I tried to do a system restore, which did not help getting wifi connectivity back. The device said it was working, but did not get any wifi connection and did not discover any networks.

What I tried next was to uninstall the device from my Device Manager and install either the current drivers found through windows, then I tried the same with the current drivers on the HP driver page. both of those attempts failed. It always tells me that installation failed when I uninstall and reinstall drivers. If I try to update the broken driver via internet, it tells me it is up to date, and in the device manager it still views as broken.

Next, I 'played' around a bit and reinstalled drivers, and I managed to install drivers from 2012, and when trying to update drivers manually and picking drivers that match the device, it lets me choose between drivers from 2010 and 2014. 2014 would be the current one, picking the 2010 driver leads to the driver being accepted. However, no wireless network can be found.

I'm pretty much out of ideas by now, short of reinstalling. The only option I can still think of was that the device broke at the exact moment I installed the new windows driver, but I find that a bit unlikely. Any help would be appreciated fixing this issue.

Edit: Update, I finally got the time to try a live system, the device works with Ubuntu, I get a proper wifi connection with it.

Edit 2: Windows 7, all Updates installed, 64 bit

Device IDs: Device IDs

  • Using the restoration point should have worked. We need more information about the installation failure. – Ramhound Jun 11 '14 at 18:24
  • Reinstall the OS, or try another OS: Does it work? Software issue. Does it NOT work? Hardware issue. – Ƭᴇcʜιᴇ007 Jun 11 '14 at 19:12
  • Silly question but we should cover the basics, have you made sure the wireless switch or button is toggled ON for the laptop? even if you never turn it off or press it there is a chance, so check it. – RyanTimmons91 Jun 11 '14 at 19:46
  • @RyanTimmons91 The switch doesn't work on this device anymore, as I uninstalled the HP suite to listen to these buttons/switches years ago (another story). But, I did toggle the switch to satisfy your curiosity, it did not help. – private_meta Jun 11 '14 at 20:52
  • 1
    Try booting any Linux live distribution and check whether the wireless card work fine there. – and31415 Jun 12 '14 at 0:31

Try this if it happens to anyone else after the update. Works on EliteBooks (8460/70. 840, 850 and 1040)

  1. Right click on "Computer" and select Manage
  2. Select Device Manager from the left
  3. Double click on the wireless driver under Network adapters
  4. Select the Driver tab and click on "Roll Back Driver"

The wifi should start working again instantly.

Ensure you do not install the update from MS Update again. I have seen it break the wireless on all of the machines mentioned above,

  • "Roll Back Driver" is grayed out, I can't click it. – private_meta Jun 12 '14 at 20:00

Couldn't find a solution, Decided to format the thing and install Ubuntu for now.


Try uninstalling and then reinstalling your antivirus software. Some antivirus suites come with "miniport" network drivers (for traffic filtering/analysis) and it's possible these may be having an issue. You can see these by selecting "Show Hidden Devices" in Device Manager.

  • Didn't work... but I just decided to screw it and install Ubuntu for now. Thanks anyway. – private_meta Jun 19 '14 at 17:07

I had to download Intel updates for the wireless adapter from their site. It turns out that I had disabled Intel Update Center and that caused that to happen.


I'm not sure if this will work for you, as your equipment may differ, but it did for me.

I upgraded from win 7 to win 10 and my wireless adaptor failed to function (the device driver had been either deleted or compromised in the update)--it was a CISCO AE500. The simple solution to this problem is to connect directly to your router via an ethernet cable and grab the device's driver from their support website. Install, and voila, wireless access reinstated.

I've also noticed that the drivers for graphics cards are often deleted from win 7 to win 10. NVidia drivers need simply be acquired through their support website.

I hope this helps.


I had the very same problem and figured out a solution that worked after trying everything posted on the web. My laptop is using the Intel Centrino Advanced-N 6250 AGN wireless adapter.

I used the Intel PROSet/Wireless WiFi Connection Utility to connect to my wireless router INSTEAD OF WINDOWS. This is the software that was installed by selecting the **S versioned driver files from the Intel website. Low and behold the software can see all the wireless networks in my area where Windows cannot. I connected using that utility and my wireless has been restored.

If your wireless connection doesn't work through using Windows Networks use the WiFi connection utility by Intel instead. An extra step but it works and I can keep installing windows updates and not get stuck on my level because I have to roll back.


I know this is an old thread but I recently came across a similar problem, and wanted to explain how I got it working again.

So for me, I installed a modded driver for my graphics card, everything went smooth, then I did the reboot and my wifi was gone. I don't know why, but installing the new graphic drivers messed with my wifi drivers. All I had was the Ethernet connection icon and not the wifi anymore.

After a hair-pulling hour, this is how I managed to get it working again. First using my phone since I didn't have another pc, I downloaded the wifi driver for my laptop, then transferred it to my pc using a usb cord. (was too lazy to move my pc to connect it by ethernet)

I installed it, and no wifi. I rebooted, and still no wifi icon, just Ethernet. After checking all the services, I went into Device Manager, then network, and saw the wifi driver was in there. I right-clicked on it, and selected Scan for hardware changes. Nothing seemed to happen, but then all of a sudden my wifi came back like magic.

So perhaps this process will help someone else. Just figured I'd add it.


Uninstall or disable current driver. Reboot and see if Windows recognizes the device. If so install correct device driver. After that use Windows networking to connect to internet.

If it continues not to recognize you can try another card.


Just as a side note, I also have an HP (Dv-7) and the update killed my wireless as well. Perhaps it is an intel wireless problem? I'm not 100% sure (without doing some research) if HP uses Intel wireless adapters exclusively, but simply running the restore back an update made it work again. Oddly enough, the update also killed my bio-metrics for login.

  • This appears to be the same solution described in Chris's answer. Can you clarify how it is different, if it is? If it is the same solution, then this response is just a comment confirming that it also worked for you, which doesn't meet the definition of an answer on SU. – fixer1234 Dec 1 '14 at 7:45
  • Unfortunately, this doesn't answer the question. If you need clarification or have a question or concern about another post, please leave a comment on that post—you can always comment on your own posts, and you can comment on other people's posts once you earn 50 reputation. This area is for answers, so your post will likely be deleted shortly. – bwDraco Dec 1 '14 at 9:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.