0

Hi I am building a ROR development environment on a windows 7,

I have Ruby version 2.0.0 and Gems version 2.2.2 installed. Which version of Rails should I install?

I saw this on rubyonrails.org/download : "We recommend Ruby 2.1.0 for use with Rails. We stopped supporting Ruby 1.8.x after Rails 3.2. Ruby 1.9.2+ will be supported until Rails 5."

I will be working on a long-time project, I'm just trying to lessen the headaches I will have later.

Right now, the latest Rails -v is 4.1.0 and they recommend Ruby 2.1.0 for use with Rails. I think the best option is to go with this set.

Any other thoughts?

1 Answer 1

-1

A simple "gem install rails" should get you the most current stable version. I only pin specific versions when there's a clear dependency conflict between gems.

3
  • Yeah I was about to hit return after I wrote gem install rails but then I saw this on rubyonrails.org/download : "We recommend Ruby 2.1.0 for use with Rails. We stopped supporting Ruby 1.8.x after Rails 3.2. Ruby 1.9.2+ will be supported until Rails 5.
    – Ekin
    Jun 12, 2014 at 5:07
  • No, you are wrong. I had ruby 2.0.0 and I ran gem install rails and I had this error ERROR: Error installing rails: activesupport requires Ruby version >= 2.2.2. so I had to do gem install rails -v 4.2.2. and it installed successfully
    – Umair Ayub
    Aug 12, 2016 at 20:26
  • You may notice that you're running an out of date version of ruby to begin with. The error you encountered is telling you that your out of date version of ruby cannot run the newest version of rails (in this case, because the current version of activesupport requires ruby 2.2.2 or greater.)
    – Stephan
    Aug 12, 2016 at 21:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .