2

I have two disks in raid 0. I ran fsck on them and long story short, didn't fix it completely. I found it is all in a single directory. I dont mind losing this dir completely so i tried to rm it.

I have tried rm -rf as root, and deleting it using its inode number. But all I get is "ext3-fs error htree_dirblock_to_tree: bad entry in dir #********: inode number out of bounds".

I haven't found anything able to remove it. Is there some way I can get the FS just to drop the reference?

10
  • Mind sharing with us how did you run fsck?
    – Kenneth L
    Commented Jun 13, 2014 at 6:13
  • fsck /dev/md127 -- it came up with stuff like "fsck error could not allocate block" and "error allocating in block group contiguous inode table could not allocate" Commented Jun 13, 2014 at 6:17
  • have you unmounted it? Commented Jun 13, 2014 at 6:23
  • it was unmounted when i ran fsck, its mounted atm and im trying to remove this directory Commented Jun 13, 2014 at 6:24
  • do you know the /dev/sd** of the disks in raid? if so i recommend trying fsck on each disk indepently Commented Jun 13, 2014 at 6:25

1 Answer 1

1

I forgot about this post sorry :/

I found the issue. The bus between CPU/memory on the motherboard failed (just a few bits of it). Hence all the strangeness (as well as kernel panics on live images).

Thanks everyone for your help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .