0

When running Windows 8.1, some settings show up on a metro-like sidebar that comes on top of the classic Windows < 8 desktop. E.g., this happens when you press the network icon in the notification area.

Now, every once in a while, a sidebar appears but doesn't paint itself with the metro content. What happens is that it contains old content of the classic Windows < 8 desktop (I will add a screenshot when this happens again).

Since it doesn't reveal the content, and I don't know what triggers the appearance, I don't know what sidebar it is.

The only two ways to have the sidebar disappear are:

  • log off
  • reboot

I've tried other ways (like killing all explorer.exe instances), but to no avail.

Two questions:

  1. How can I find out what causes this sidebar to appear?
  2. How can I make this sidebar disappear without having to log off?

This happens on Windows 8.1 Enterprise x64 with Office 2013 Professional running full-screen inside a VMware Fusion 6.0 VM (all updates are installed, VMware tools is installed).

Edit

Today it happened again, right after resuming a VM.
This time, taskkill -im explorer.exe -f helped to get rid of the date time charm that is in the lower left portion of the screen (which still painted like it was 8 days ago).

But it didn't help into getting rid of the non-painting charm on the right side of the screen, see screenshot of the full screen.

There were virtually no running processes, see screenshot of task manager.

Windows+C doesn't hide the non-painting charm.

So I tried these shortcuts (to no avail) that normally show:

  • Windows+C: date/time overlay on the lower left and narrow search/share/start/devices/settings charms bar on the right.
  • Windows+I: wide settings charms bar on the right.
  • Windows+P: wide projector/display charms bar on the right.
  • Windows+S: wide search charms bar on the right.
  • Windows+F: wide search charms bar on the right.
  • Windows+H: wide share charms bar on the right.
  • Windows+K: wide devices charms bar on the right.
  • Windows+Space: language switching overlay on the right.

Then I started killing processes, to no avail as well until Windows BDOD-ed as I killed one too many svchost.exe process.

Note I did not use any tools like this guy to disable Metro Stuff. I'm aways wary of such hacks.

Edit 2

Using Spy++, I found the title of the charms bar: caption is Search Pane and class is SearchPane which is part of one of the Explorer.exe processes. Killing and restarting Explorer.exe using ProcExp.exe (from SysInternals) brings back the non-painting charm bar.

Pressing the Windows key, gives me a black tiles screen. So something is clearly wrong with the Metro.

  • 1
    Do you mean the side bar that appears at times? well there is 3 of them but each is activated differently – Andrew Crawford Jun 14 '14 at 12:29
  • @AndrewCrawford indeed: that one. I don't know which one it is. Which ones are there? How are they activated? How can I tell which one it is when it doesn't paint its own content? Questions, questions (: – Jeroen Wiert Pluimers Jun 15 '14 at 5:48
  • TO activate it move your mouse cursor into the corners of the screen, each corner activates a different one – Andrew Crawford Jun 15 '14 at 6:15
  • @AndrewCrawford are there other ways to activate them? As the top two corners will show the VMWare Fusion bar (so I cannot activate them) and the bottom right peeks to the desktop and paints a two small lines vertical lines about 50% from the right and 20% from the right: copy.com/0gcr8udYgq6jkg2B – Jeroen Wiert Pluimers Jun 15 '14 at 6:26
  • Open Windows Sidebar properties by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Appearance and Personalization, and then clicking Windows Sidebar Properties. Select the Sidebar is always on top of other windows check box. Click OK. only way i know to turn them on – Andrew Crawford Jun 15 '14 at 6:35
1

I'd suggest running Dism /Online /Cleanup-Image /RestoreHealth from an elevated command prompt in case there are system file corruptions, it does the same as sfc /scannow but actually fixes any errors.

Also maybe worth re-installing the display driver, or at least uninstalling it and restarting and it should re-install. Good luck, weird one!

  • 1
    Uninstalling the video driver didn't fully work. What did work was uninstall VMware Tools, then reinstall the same version of VMware Tools. Still not sure why, but after two weeks without problems, it is solved. – Jeroen Wiert Pluimers Jul 10 '14 at 13:31
1

You can use the windows key + c to toggle it open and close. Might be as simple as just pressing the key combination whenever you notice it stuck. Pressing esc also makes mine go away but if yours is actually freezing there or something, there may be something more seriously wrong. Like corrupt files or the like.

I don't know the shortcut for the other stuff but if you have a metro app open (when you press the start button and open a metro app) you can switch between desktop mode and metro mode by going up to the very top left corner of your screen and clicking. It'll show different metro apps you have open (sorta like alt + tab has done in past versions but it only shows metro apps). Nothing will happen however if you have 0 metro apps open. The charms bar on the right is a sort of settings bar for metro apps but it can be opened from desktop mode as well by moving your mouse up to the top right corner or the bottom right corner. However, if you have 2 monitors a recent windows update made it so that you have to move your mouse over to the very far right monitor, then up to the top right and bottom right. Windows key + c does the same thing however, on the same screen your mouse currently has focus so I find the shortcut keys better.

  • Thanks. Windows+C didn't work, see the edit in the question. I'm not using any metro apps (at least knowingly: I'm a desktop guy, and the severe lack of functionality in the default metro apps like the image or PDF viewer always drives me back to the traditional desktop ones). I've also listed the task manager dump, to show which processes are running. Next step is to kill them one by one and see what happens. – Jeroen Wiert Pluimers Jun 23 '14 at 9:23
  • I wonder if vmware is somehow screwing it up. Maybe an older version of vmware that has a bug with windows 8 or something? I'd try killing it first to see if that makes any difference. Also check for any new windows updates. They may have fixed something that caused this to happen. – Codezilla Jun 23 '14 at 9:32
  • Thanks for the help. VMware Fusion 6.0.3, with latest VMware Tools 9.6.2.1688356 installed on Windows 8.1 Enterprise that is completely up to date with patches. I'll keep an eye on this to see when the issue happens again. – Jeroen Wiert Pluimers Jun 23 '14 at 9:43
  • You could try and disable the charms bar too, it might stop whatever is causing it altogether. Not the ideal solution though probably. superuser.com/questions/399029/… – Codezilla Jun 23 '14 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.