2

I used to use Linux Mint 13 MATE for some time, it has MATE 1.2.0, in which I can set Ctrl+Esc shortcut for opening main menu by right-click on the Menu button -> Preferences, there is a simple text field in which I can manually enter the following text: <Control>Escape, and it works. (logoff + logon is needed to apply changes, though)

Now I tried Linux Mint 17, it has MATE 1.8.0, and there is no text field anymore: now, there is automatic shortcut picker. The thing is that it fails to grab the same shortcut: just when I press Esc it doesn't care that I actually hold Ctrl key already, assumes I canceled entering, and just returns previous value.

It's interesting that in general keybinding settings (mate-keybinding-properties) shortcut picker is more smart: it easily allows to enter shortcut with Esc key. But, in the mate-keybinding-properties, it's impossible to set shortcut for opening main menu. (iteresting why it is separated, btw)

So, how to achieve what I need: how to set Ctrl+Esc shortcut for opening main menu?

2

After some experiments, got it: first of all, we need for dconf-editor:

$ sudo aptitude install dconf-tools
$ dconf-editor

Go to comlinuxmintmintmenu, find hot-key property, and set the following text there:

<Primary>Escape

Note it's case-sensitive. After that, the hotkey should work immediately (even without closing dconf-editor, or anything)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.