1

I have windows 7 and downloaded a program (.exe possibly containing a virus), but didn't install it. Then I right clicked on the program > open with > notepad (always use this program not selected), which opened notepad with an error. All programs got the notepad file icon and opened with notepad.

After searching Microsoft help pages and contacting technical support, I followed this article http://support.microsoft.com/kb/2688326. Which solved the problem (i can now run programs). However now if I right click on a program which is supposed to say run as the first option it says "%1" %*

can someone with Windows 7 home premium tell me what it says in the three registries, it speaks about in the link.

@Amirreza Nasiri your answer is only based on a spelling mistake I made (and corrected) in the question. and therefore didn't solve the problem.

  • There is no such article on the URL. "The page you are looking for may have a new location, or is no longer available." – Amirreza Nasiri Jun 15 '14 at 23:21
  • I fixed it. it was /kb/ not /gb/. – Arye Eidelman Jun 15 '14 at 23:28
0

According to the article, in the "Let me fix it myself" session steps 8 and 11 where you should change the Value data: to "%1" %* at both these paths:

HKEY_CLASSES_ROOT\exefile
HKEY_CLASSES_ROOT\exefile\shell\open

You made mistake and changed it to "%1"%* instead of "%1" %*. You should note that there is a Space character between second quotation mark and second percent characters.

  • so i should change it back, I presume? – Arye Eidelman Jun 15 '14 at 23:36
  • @743 Yes you should change it back to "%1" %* – Amirreza Nasiri Jun 15 '14 at 23:45
  • +1 for fast response i spent two hours 'chatting' with Microsoft while they tried to get me to buy premium support for $150 and get all the information they could about my pc – Arye Eidelman Jun 15 '14 at 23:50
  • You can get a lot of guidance on the internet without paying anything. :) – Amirreza Nasiri Jun 15 '14 at 23:53
  • i didn't realise it would be so fast – Arye Eidelman Jun 16 '14 at 0:04
0

instead of typing "%1" %* in the last two registries type Run .

thanks to Microsoft support.

apparently it just needs to be the same characters in both registries. (that's how i understood it.)

0

What you have to do is go back to where you changed the file under exefile/open and then clear it and also clear the sub folder under open also which is called command and it will correct it back to normal seeing is that was the default values befor e the change.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.