1

I've spent hours trying to get a Oki C8600 printer working using Windows printer sharing. Let's call the three computers involved the following:

WinXPserver - The Oki printer is connected to this Windows XP computer with a USB cable. Printer sharing is enabled over the LAN.

Win8working - The shared printer works fine from a Windows 8 computer.

Win7broken - I can add the shared printer, but any jobs sent from this computer just get stuck "spooling". The job does appear in the printer queue when I look on WinXPserver. But it just sits there until I delete it from the queue.

The driver says it does support Windows 7. I've tried heaps of things and reinstalled the drivers multiple times etc.

I was about to give up, and just noticed that that there is a difference on Win7broken vs Win8working.

When I right-click the printer on Win7broken and click Properties, then look on the Hardware tab, nothing is listed in the Device Functions: box. You can see a screenshot here: http://imgur.com/KNqAVcy

On Win8working, this same window lists the network path to the printer. What could cause this to be empty on Win7broken? I'm guessing this is the reason it isn't working.

Thanks!

6
  • Were they added using the exact same method? – Michael Frank Jun 17 '14 at 0:48
  • Yes, I've installed the driver/set up the printer using 3 different methods, each time using the same method on both the Win7 and Win8 computers (so 6 installs in total). The result is always the same, always works on Win8, and never Win7. – LaVache Jun 17 '14 at 0:54
  • And what happens if you remove the printer from the Win7 machine, then use the Add a Printer > Add a Network Printer dialog under Devices and Printers? – Michael Frank Jun 17 '14 at 0:57
  • This was one of the 3 methods. I've just tried it again to be sure, and same result. Do you know anything about that "Hardware" tab / "device functions" list and why it could be empty? Thanks for your help. – LaVache Jun 17 '14 at 1:26
  • One thing I might know the tab having nothing in it , is probably not the problem, a similar oki here works fine and there isnt anything there either. Plus didn't you indicate that it landed at the server, but is just not printing? Dont know what to tell you except to Right Click and select "Printer Properties" (not "properties") check out the info in every tab there, the port it heads to and all, in advanced tab, the spooler settings, and compare betwen the 2 systems. Then in the "printing preferances" for what? making sure the tray selection and any weird stuff in Job Options Advanced. – Psycogeek Jun 17 '14 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.