3

We have Huawei Y530 and Y300 smartphones.

When we connect either of these with the USB cable to either Windows 7 or Windows 8.1, the operating systems say "USB Device Not Recognized".

No USB driver came with the phones when we bought them.

On the Huawei website for these phones there is no USB driver to download, e.g. on the Y530 page it says "Sorry, no results were found": http://consumer.huawei.com/en/mobile-phones/support/downloads/ascendy530.htm

On the Huawei website under popular downloads, I found: "Huawei Android Phones USB Driver" http://consumer.huawei.com/en/support/downloads/detail/index.htm?id=11802 which is a zip file which contains DriverSetup.exe. I executed this and it installs the driver software, allows me to install them:

enter image description here

And then reports that they were installed:

enter image description here

However, after installing this on both Windows 7 and Windows 8.1 on two different computers, even after rebooting both machines, the Huawei Smartphones still are not recognized via USB cable, the operating systems still say: "USB Device Not Recognized".

What else can I do to get Windows to recognize these Huawei smartphones via USB?

10
  • 3
    Does the phone have a USB mode that needs to be changed - a few Android phones have different modes like Mass Storage, Media Device etc. in the "Connections" page in "Settings"...? – Kinnectus Jun 17 '14 at 8:47
  • I can't find anything in the phone settings that mentions USB, and when I connect the USB cable, there is no window that pops up as on my older phone (HTC). I can't find anything in Google which mentions setting up the USB connection on the Huawei phone. – Edward Tanguay Jun 17 '14 at 9:00
  • Are you able to check on another OS - not Win7, 8 or 8.1 - something like XP or Linux? – Kinnectus Jun 17 '14 at 9:09
  • Not at the moment, but on the phone, I did search for USB in the app store, and installed "Software Data Cable" which enabled me to access my files read-only via a local ftp address. Interesting. But I want to develop Android apps on this phone so I am looking for a standard USB connection. – Edward Tanguay Jun 17 '14 at 9:20
  • Are there -any- USB settings on your phone? Go through all the menus and see what you can find... – Kinnectus Jun 17 '14 at 9:23
1

I have Huawei Ascend Y300 and had lot of trouble getting it in developer mode for Android app dev. However, once I installed drivers from Huawei on my Windows 8.1 laptop it started showing up on ADB:

Here are some additional tips that might help:

  1. Before turning Developer Settings ON, turn FASTBOOT off on your Android phone.
  2. Also, restart the phone.
  3. With Developer Settings On, Stay Awake checked connect the phone to your PC.

Needless to say, have Device Manager running and Android Studio running, to see how your device shows up.

2
  • the link is broken – naXa Nov 9 '15 at 10:51
  • Fast boot not to be confused with FASTBOOT – esQmo_ Mar 22 '18 at 15:18
1

Plug in the Hauwei Android phone to the USB port on your computer.

Pull down notifications on the phone. One of the selections should be 'USB Connection Type'. Short press it and you will get three options. Choose the 'USB Connection' option. You should then be able to use the phone's storage as both read and write enabled.

0

What I found you have to use USB cable coming with the box, the drivers have been preinstall in the phone. I tried other USB cable it did not work. OK, good luck.

0

I tried everything to get the usb connection to be recognised by windows 7.

I had sort of given up and then I connected the phone to the computer using the usb connection for a Logitech harmony 600 controller and, unbelievably, everything suddenly worked. I have no idea why but that is what happened!

0

Use USB cable to connect phone to PC. From options displayed - Install 'Huawei Hi Suite' on your PC.

On Phone, Flick down from top of screen. Select (tick) 'Connect to PC Software' also select (tick) 'USB Debugging '.

'Hi Suite' should now kick in and complete the connection.

Good luck. Worked for me in UK !

0

I had trouble getting access to the drive once connected via USB to my PC using my Y6II.

Once you plug the lead in, it kept saying charging only. After I plugged the USB lead in, I swiped down from the very top of the screen and it then gave me options to either charge only or to access photos or files.

Once I selected the files box, Windows 7 installed some more drivers and finally the standalone drive window appeared and I was able to gain access to the internal memory of the phone.

Unfortunately it would appear that you have to swipe down from the top of the screen every time you plug in your phone to access the drive. I hope this helps anyone else puzzled with the charging only message.

0

Until a couple of minutes ago, I had the same problem with my Y360-U03. The usb connection setting in Notifications was set to "USB Storage - XP recommended", didn't work in W10, nor in XP running in VirtualBox. Tried connecting as "Media Device", this showed the phone system files, but not my pics. Then connected as "Camera" - all good. Another slight wrinkle was that it would appear in Explorer, but not in FreeCommander XE.

0

On my Y300, I had to change the default storage setting from internal storage to SD storage so it then gave the option to have Camera, and USB Mass storage settings and boom the PC can see it now.

-1

You must turn on the phone as normal, then simply connect the usb cable to an empty USB port. The SD card and internal memories should both appear as separate drives (eg I: and H:) on explorer with their respective folders. I have a Y300 and Windows 8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.