I am testing a Python3 program in several computers. To do that, I need to install a library of Python with pip3.

So first, I was installing python3-pip in each computer (everyone is running Kubuntu OS). Everything was OK, and then I installed the package I needed with pip3, and I managed to do that except for one computer.

In that computer, python3-pip was apparently installed succesfully, but when I look for the package, I get this error (the translation is homemade):

Command «pip3» was not found, maybe you wanted to say:
 The command «pip» from the package «python-pip» (universe)
pip3: command not found


Results of dpkg -L python3-pip:

  • Could you maybe accept the answer, if it was helpful? This marks the question as resolved and will help future users.
    – MERose
    Nov 8, 2016 at 16:00

4 Answers 4


One of three things will likely fix it:

  1. In case python3-pip did not install correctly, re-install it:

    This is used for Debian-based distros like Ubuntu, Mint:

    sudo apt-get remove python3-pip; sudo apt-get install python3-pip

    If using Fedora, CentOS, RHEL, please use:

    sudo dnf reinstall python3-pip
  2. Try using the command python3-pip instead (works on Fedora; I don't have a copy of Kubuntu to try it on).

  3. Just a wild guess...check pip --version. There is a slight possibility that after installing python3-pip the new pip would replace the old pip (perhaps via alternatives?)

Now that the output of dpkg -L python3-pip has been added to the question, I can provide the answer.

The correct command name to use is: pip-3.2.

  • 2
    It's not possible to reinstall python-pip3 (in Fedora at least), since dnf depends on it. In my case, I have python-pip3 installed, it should have installed /usr/bin/pip3, but didn't. rpm -ql python3-pip|grep bin/pip3 shows /usr/bin/pip3 /usr/bin/pip3.5, but ls /usr/bin|grep pip3 doesn't find them.
    – dfarrell07
    Jan 3, 2017 at 17:54
  • 2
    @dfarrell07 Wrong. You are not allowed to dnf remove it, since dnf depends on it. However, you are allowed to dnf reinstall it, which is what is needed anyways. dnf (and yum before it) is smart enough to know that reinstalling a needed package is OK even if removing it isn't.
    – BenjiWiebe
    Jan 31, 2017 at 5:38
  • That wasn't in your answer, but I updated it to make it clear.
    – dfarrell07
    Feb 1, 2017 at 15:08
  • 1
    should based on the python version, such as python 3.6, pip-3.6
    – Xin Meng
    Nov 21, 2018 at 17:09
  • @XinMeng Correct. I was pointing out that the command name from the dpkg output is pip-3.2. Obviously the dpkg output will be different for a different version of pip.
    – BenjiWiebe
    Nov 30, 2018 at 3:55

I ran into this problem and found the solution. The python3-pip package installed a pip-3.2 binary.

Executing pip-3.2 --version shows:

pip 1.1 from /usr/lib/python3/dist-packages (python 3.2)

Whereas python3-pip gives the command not found message.

I tested it on a "clean" download from here: https://sourceforge.net/projects/rpiqemuwindows/

I checked for pip-3.2 before installing python3-pip and then after.

  • 1
    pip-3.6 now, in my case - this worked. Thanks and +1
    – cssyphus
    Apr 4, 2018 at 2:39

If you have several Python versions installed, you might get:

bash: pip3: command not found...
Packages providing this file are:

Listing the installed pips shows why:

$ ls -l /usr/bin | grep pip.*3

pip-3.6 -> ./pip3.6
pip-3.9 -> ./pip3.9

Resetting pip3 link could resolve it:

$ sudo ln -s /usr/bin/pip3.9 /usr/bin/pip3
$ pip3

  pip3 <command> [options]

You can use use easy_install:

apt-get install python3-setuptools
easy_install3 pip
  • 2
    Can you clarify what this does and why it works?
    – fixer1234
    Mar 31, 2017 at 1:48
  • This might be solution, but the question is oriented more to finding out what cause the error rather than finding the solution. Jul 21, 2017 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .