I'm running Outlook 2007 under Windows 7 Home Premium RTM. My OST file was previously being properly indexed but eventually searches significantly slowed down so I suspected a problem. Searching and indexing appears broken in OneNote 2007 as well as search time is now significantly longer.

I brought up the Outlook 2007 Search Options dialog and noticed that my mailbox (running from an Exchange 2007 server) wasn't listed in the "Index messages in these data files:" list box.

enter image description here

Next I ran the Windows "Find and fix problem with windows search" wizard which reported no errors.

Then I brought up the Windows Indexing Options dialog which shows Outlook listed (as shown here):

enter image description here

then clicked Advanced and Rebuilt the index. No dice - the listbox in the Outlook 2007 dialog still didn't show my mailbox.

When I clicked the Modify button in the Indexing Options dialog I see the following:

enter image description here

When I hover over the "oneindex://..." entry, the alt text indicates "This location is currently unavailable". When I delete it and rebuild the index, this entry returns.

UPDATE: Comparison of the last screenshot above with a working PC shows that on the broken PC, the lower half of the dialog lists Outlook but neither Outlook or OneNote are showing in the upper half. The working PC has Outlook and OneNote in both parts of the dialog.

1 Answer 1


Try looking over this article from Microsoft:


From the article:

"If you use a Microsoft Exchange account (much more common in business e-mail systems than in a home or personal account), you must be connected to the server running Exchange and use Cached Exchange Mode for Instant Search to index your messages. Cached Exchange Mode uses an Offline Folders file (.ost) to save your information on your computer. To verify which data files are being indexed, do the following:

1.On the Tools menu, point to Instant Search, and then click Search Options. Alternatively, click the arrow in the Instant Search pane, and then click Search Options on the menu.

2.Under Indexing, verify that the data files that you want to include in your search are selected in the Index messages in these data files list."

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .