4

I have Fedora 20 + VLC 2.1.4. Whenever I change the volume in VLC, it affects the volume of my system as well.

Is there some setting/config that I can modify to prevent this from happening?

  • 1
    How do you change volume? Are you using keyboard multimedia keys? – Cornelius Jun 17 '14 at 17:42
  • I'm using the scroll wheel to change volume. – Utkarsh Sinha Jun 18 '14 at 11:02
5

This is due to PulseAudio configruation.
As mentioned here http://wiki.gentoo.org/wiki/User:Feystorm#PulseAudio_per-application_volume_control

PulseAudio supports per-application volume control, but by default this doesnt do much as you can only control these volumes from the pulseaudio volume control utility. Meaning that in an application like Audacious, when the output device is set to PulseAudio, and the volume control is set to hardware, it will adjust the master volume control, not the per-application volume control.

So, to fix this behavior set flat-volumes = no in /etc/pulse/daemon.conf to enable per-application volume control.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.