4

It would be really nice to have matplotlib in my cygwin environment. I have 64-bit Windows 8 with 64-bit cygwin.

When I type:

pip install matplotlib

I get whe following error message:

 * The following required packages can not be built:
 * freetype

As per apt-cyg I have following packages already installed:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

What else does it need? How to install freetype & matplotlib properly?

9

I had the same problem on Windows 7 64-bit; I solved it by installing the Cygwin packages pkg-config and libX11-devel before typing easy_install matplotlib==1.1.1 (the 1.3.1 version is having errors on my machine, hence the 1.1.1).

  • Thanks for suggestion, I'll try it. As for me, I just use matplotlib outside cygwin (normal Windows installation). – Alexey Petrenko Aug 5 '14 at 12:21
3

I also had the same problem on cygwin Windows 8 64-bit. I followed the advice in another response (install pkg-config and libX11-devel) but the package that finally allowed me to install matplotlib was libfreetype-devel. Then just easy_install matplotlib==1.4.2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.