3

My host OS is windows 8 and my guest OS is lubuntu. Basically, I am trying to run a Django server form my guest OS on 0.0.0.0:8000 so that I can access it from my host OS.

I posted how I can access the server from my host OS on stackoverflow.

In the post, one of the users suggested that I should change the network to 'bridge-mode'. What I tried was this:

  1. I went to VMWare Player
  2. Clicked 'Player -> Manage -> Virtual Machine Settings'
  3. Changed 'Network Adapter' from 'NAT' to 'Bridged'

After doing this, my guest OS lost internet connection. I ran the django server on 0.0.0.0:8000 and could access it by going to either 0.0.0.0:8000 OR 192.168.174.233:8000 from the guest OS (my guest OS's IP address is 192.168.174.233.. my host OS's IP address is 192.168.2.37), but I couldn't access it from either of the two links from the host OS..

Am I bridging the connect correctly or am I doing something wrong?

  • VMware will sometimes disable a network connection when you change the adapter type so double-check that. In addition, you might need to restart the interface (ifdown eth0; ifup eth0) or restart the system. Bridge will attach the VM directly to the host's network, Host-only creates a network that only the VM and host exist in, and NAT is basically the same as Host only except VMware will also perform NAT between the Host-only network and the actual network the host is connected too, if necessary. Any of those should work assuming you're using the correct IP address and firewalls aren't enabled – nijave Aug 26 '16 at 0:04
  • Do an "ip addr", "sudo netstat -tlpn" (while the Django server is running), and "sudo ufw status" on the guest. That will show you the guest's IP address(es), what programs are listening on TCP ports, and whether you have uncomplicated firewall (ufw) turned on. – nijave Aug 26 '16 at 0:06
0

I had the same problem. I solved disabling Citrix DNE Lightweight Filter from my network adapter properties. If you are using a Realteck adapter, you can take a look at KB1025978 and KB1015940

You can check this question VMware Workstation Bridged Network Host UnReachable

0

Perhaps you want to try adding a host-only network? In preferences, under the network tab, add a host only network (vboxnet0). Then go to your VM and add it as a second network adapter. Finally, when you're running your server, make sure you host on 0.0.0.0,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.