2

As a friend of mine pointed out earlier tonight, Winamp is really a great program. I agree.

The only thing stopping me from using it on a regular basis is that Windows Media Player supports use of the playback buttons on the keyboard, while Winamp does not....or does it?

Question: How to set up the playback buttons on the keyboard to work in Winamp instead of WMP?


My computer is running Windows 7 Starter (lame, I know;)

Not a duplicate -- that question was asking about making the dedicated "open a media player" button to open Winamp instead of WMP....I want the play/pause button to play/pause Winamp after it's already open.

2
  • Should I use the Windows tag, or the Windows-7 tag? ....I'm running Win7, but this is probably the same across versions of Windows....if you think I did it wrong, leave me a comment or just fix it! Thanks :)
    – Shokhet
    Commented Jun 18, 2014 at 3:19
  • If it were the same, there's won't be a tag for every version of Windows. You picked the tag correctly
    – matan129
    Commented Jun 18, 2014 at 4:36

3 Answers 3

4

Yes, Winamp does support global media hotkeys automatically, as long as another program does not usurp those hotkeys. This can happen if you open another program that hooks to those hotkeys after Winamp is opened.

This is supported by a plugin that should be enabled by default, the Nullsoft Global Hotkeys plugin. Additional hotkeys can be enabled. Interestingly, my Winamp instance will accept media hotkeys even though global hotkeys are disabled in the preferences dialog.

The default media hotkeys are Stop, Play/Pause, Previous track in playlist, Next track in playlist

5
  • Thanks for the answer....I looked at 'Plug-in' in the menu....enabled Nullsoft Global Hotkeys plugin.....was told "Hotkey registration failed! Could not register the following hotkeys: Volume up/Volume down/Forward/Rewind"
    – Shokhet
    Commented Jun 18, 2014 at 18:02
  • 1
    Also the play/pause button still doesn't work for Winamp...am I missing something?
    – Shokhet
    Commented Jun 18, 2014 at 18:03
  • The hotkey registration, or "hook", is critical for it to work. Another program may be hooked and is not allowing Winamp to take it. See if wmplayer is running in task manager (also itunes, doubletwist, etc) Commented Jun 18, 2014 at 20:09
  • Never mind; it worked....apparently just needed to restart my computer....thanks again!
    – Shokhet
    Commented Jun 20, 2014 at 19:28
  • I am also fond of additionally mapping the keyboard's built-in "Pause" button. Not the media one. The one next to scroll lock. Advantage: Works for all keyboards consistently.
    – ClioCJS
    Commented Aug 26, 2015 at 6:27
0

I was able to fix this issue specifically for myself by disabling media key usage in chrome, as I had YouTube open and it was trying to control YT first.

If this happens to you, open a new tab in chrome, put chrome://flags/ search for Hardware Media Key Handling and set it to Disabled. Relaunch Browser.

0

In Windows 10 I just had to enable them in the Preferences -> Global HotKeys: preferences screen

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .