7

I did recently upgrade my little NAS to ubuntu 14.04 and initially everything worked fine. I'm used to re-import my ZFS pools after restarts and so it was no surprise when the mount point was gone after a restart 2 days ago. But this time i was not able to re-import it and when i started looking closer the whole ZFS dataset disappeared too and i start to run out of ideas what to try (as do the google results i find).

$ zpool list or zpool status no pools available

$ zfs list no datasets available

$ ls /dev/disk/by-id/ ... disks as i have used them in my config ...none missing

Everything was working fine before a reboot 2 days ago, and before that reboot i did run some upgrades including the kernel (standard upgrade via apt). Re-installing/further upgrading or going back to previous versions (selected in grub) all did not help.

It would be really cool to get it back running, especially since i switched to ZFS for its promised reliability. The nice data redundancy does not help me if the whole storage disappears out of nowhere...

Any ideas?

  • 1
    going through all the possible steps again today i got a nice surprise as "zpool import" suddenly did show my pools again, and i was able to import them. i still have no idea why or what was going on as i'm quite sure i tried that before - several times even. without luck. – maxigs Jun 20 '14 at 7:31
10

I had the same Problem. Doing

apt-get install ubuntu-zfs zfsutils

and rebooting solved it for me. For some Reasons ubuntu did not update all zfs-packages. You can see if this is the case at the end of apt-get update output (packages held back)

protected by Community Oct 2 '14 at 16:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.