I'm trying to log in to the corporate intranet. It used to ask me for a password in Firefox.

But suddenly it stopped to do so, and only shows an HTTP 401 Unauthorized error message, just like when you cancel the prompt.

I tried to use livehttpheaders to see if it tries to send wrong credentials but it doesn't send anything in the headers.

Tried the do same on another computer. I got the same headers but it did show the authentication prompt. So I can progress an authenticate.

I tried to delete all history, create a new profile, but no avail.

It works with other browsers and works on another computer on the same operating system with the same version of FF too.

So it seems some of the global settings were screwed up in my FF. Does anybody how can I get my prompt back?

  • You might want to just uninstall the browser, use something like CCleaner to clean out temp files and obsolete regstry entries, and then install the browser again. – MonkeyZeus Jun 19 '14 at 16:27

NTLMv1 authentication has been disabled by default in Firefox 30. To enable, the pref network.negotiate-auth.allow-insecure-ntlm-v1 needs to be set to True. See: https://developer.mozilla.org/en-US/Firefox/Releases/30/Site_Compatibility (down the page under "Security").

| improve this answer | |
  • 1
    They also deprecated it. So does this mean in a future release non-windows users won't be able to authenticate to the intranet at all on Firefox? – Calmarius Jun 24 '14 at 11:15

I set: network.negotiate-auth.allow-insecure-ntlm-v1 to true

and now I am getting the prompts again.

| improve this answer | |
  • From the name of the property, it sounds as thought this is not a good option to set. Do you know otherwise? – BenjiWiebe Jun 23 '14 at 19:21

You could try running Firefox in Safe-Mode to see if it helps you troubleshoot the issue.

Otherwise, I would take a look at your Preferences -> Security -> Saved Passwords. You might want to try deleting the intranet site if it is saved there.

| improve this answer | |
  • Starting FF in safe mode does not fix the issue. I don't have any saved passwords. (I usually have one master password combined with the website's name, so it's easy to remember) – Calmarius Jun 19 '14 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.