Shift+End is supposed to select all the text from the current position to the end of the line. For some reason my computer stopped behaving that way yesterday. Now my cursor doesn't move when I click Shift+End.

More Details:

  • Nothing happens when Shift+End is clicked
  • The End button and other combinations like Ctrl + End work
  • Other combinations like Sift + Home and Shift + PgDn work
  • Every application is affected
  • Alas, a simple reboot did not fix the problem
  • I haven't installed any new software recently

Any troubleshooting tips would be greatly appreciated.

  • Wait... Rebooting DID NOT fix the problem?! I'm at a loss... I suppose the obvious question is: Did anything change yesterday before the problem arose? Install any software, configuration changes, etc? – Wutnaut Jun 19 '14 at 18:01
  • Is there a difference if you use the left shift or the right shift? – ernie Jun 19 '14 at 18:19
  • have you confirmed that your keyboard layout is correctly detected? have there been any changes to your keyboard drivers in Device manager? have you tried unplugging it and plugging it back in have any impact? – Frank Thomas Jun 19 '14 at 18:27
  • Does your cursor move to end of line if you press End alone? – nidhin Jun 19 '14 at 18:33

I'm using the Sculpt keyboard and I just updated the Microsoft Mouse and Keyboard Center hoping that it would fix the problem. After the update, I noticed (thanks to new on screen notifications) that hitting Shift+End would toggle the Scroll Lock. This caused me to look at my Scroll Lock key and notice that the bottom left corner was stuck down. After fixing the key everything went back to normal.

Interestingly, now that the key is fixed Shift+End no longer toggles the Scroll Lock. It must be some sort of fall-back in case the Scroll Lock key is jammed. I did a quick search but couldn't find any documentation on this.

TLDR: the Scroll Lock key was stuck but I didn't notice it.

|improve this answer|||||
  • fricken scrolllock. I used it once for CICS sessions in the late ninties and never since. – Frank Thomas Jun 19 '14 at 18:43
  • wierd. my shift+end wasn't toggling Scroll Lock, but toggling SL itself once actually fixed the issue.... o.O mysterious world – puslet88 Jan 16 '16 at 11:19

Be sure that Num Lock key is turned on if your computer has number pad. For me it worked normal after pressing NumLock Key.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.