8

This question already has an answer here:

I'm on a Windows 8.1 laptop (Thinkpad T440s). For some programs to not appear blurred/scaled, I have to access the .exe properties, go to Compatibility and "Disable display scaling on high DPI settings."

This is pretty annoying to have to do for many applications, and whenever I install a new program. Is there a global override I can use?

marked as duplicate by kinokijuf, Tog, Kevin Panko, Breakthrough, Doktoro Reichard Jul 2 '14 at 16:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What is your DPI set to? – dzampino Jun 19 '14 at 18:12
  • @MattSteelblade This is a 14-inch 1920×1080 display, so I'd estimate about 157. – wchargin Jun 19 '14 at 18:13
  • Open up "Personalize" by right-clicking on the desktop and then click on "Display" which can be found on the lower left hand side of the window. It almost sounds like the default DPI settings are off, but you should be able to change all of them there – dzampino Jun 19 '14 at 18:17
  • 1
    @MattSteelblade Perfect! Setting that to "Smaller (100%)" fixed everything. Thanks very much. If you write this as an answer I'll accept it to close the question. – wchargin Jun 19 '14 at 18:25
4

Open up "Personalize" by right-clicking on the desktop and then click on "Display" which can be found on the lower left hand side of the window. It almost sounds like the default DPI settings are off, but you should be able to change it there.


EDIT:

To answer Anderson's question below, you need to know some background info. There are three levels of DPI awareness starting with Windows 8.1: Not DPI Aware/Unaware, System Aware, and Per-Monitor Aware. The applications themselves determine their level of DPI awareness. Applications that are DPI Unaware are scaled up through a feature call DPI virtualization. It is this DPI virtualization feature that scales the application and introduces blurriness when doing so. Unfortunately, at this time, there is a non-trivial number of programs that do not support DPI-scaling. Even Microsoft's own Office suite doesn't yet support Per-Monitor DPI Awareness (2017-8-24).

By setting the DPI to 100%, there is no scaling, hence no blurriness.

To see what level of DPI awareness applications support, you can use the wonderful Process Explorer tool. Using Process Explorer, Select the View file option menu, and in the drop down menu, select Select Columns…. In the window that opens, select DPI Awareness. Process Explorer will now list all the running applications with the DPI Awareness column which will list one of the three aforementioned options.

  • 10
    How is this the answer to the question? I want to have a 125% DPI, but I do not want applications to be blurred. It turned out that OP simply didn't know how to set the DPI to 100%, which is a different thing. This answer basically says to make all things smaller in Windows (hard to read for someone like me), but it does not solve the problem of turning off the high-DPI scaling for all applications, which was the asked question. – Anderson Oct 3 '16 at 20:21
  • I don't know about this guy ^^^ but your solution is exactly what I was looking for. Everything was blurry because it defaulted to 125%. Setting back to 100% fixed it for me. Unless you want to go up to 200%, anything other than native resolution will be somewhat blurry because everything has to be antialiased. Perhaps what he was looking for was ClearType? – NielW Aug 23 '17 at 22:20
  • @Anderson I know it's been almost a year, but I hope my edit answers your question. – dzampino Aug 24 '17 at 15:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.