0

I have a somewhat strange problem. I run SL6.5 (a RHEL clone) and a couple months ago updated the kernel. The kernel release notes can be found here. I updated to the 431.17.1 kernel. During boot, the boot process mostly completes, but it hangs right before the login screen appears. If I boot to the older kernel (431.11.2), everything boots fine. The 431.20.3 kernel acts just like the 431.17.1. Below is the screen when it hangs (I apologize for the quality/glare, there is no good way to take a screen cap during boot).

enter image description here

Note that sshd has sucessfully started at this point, so I booted into a liveCD onto one of my co-workers desktops and used ssh to connect to the computer. The connect worked fine, I was able to navigate my root file system, and even started matlab using X11 forwarding which appeared without issue.

I have tried looking at the /var/log and don't see any major errors occuring during boots. I am wondering what I can do to sort out what is causing this, and how I might fix it.

4
  • Looks like it hangs at "atd" do you know what that is./ – Ramhound Jun 20 '14 at 15:50
  • no, but I turned it off in ntsysv, and it just stopped right after the crond. – Godric Seer Jun 20 '14 at 15:53
  • You need to determine what it is or figure a way to skip atd and crond – Ramhound Jun 20 '14 at 15:54
  • I turned off the last 4 services on the list one by one and it had no effect. And is the last service to start before the login screen appears. I think it is hanging somewhere in between. – Godric Seer Jun 20 '14 at 16:23
0

After trying to figure out what was hanging by using ntsysv to turn off services shown in the image in the question and getting nowhere, I decided to see if it was the actual display of the login screen that caused the problem. I checked, and NVIDIA had released a new driver, so I downloaded it an booted into run-level 3 to install it. At this point I realized that the new kernel booted fine in run-level 3.

After installing the new driver, the new kernel booted without issue. I don't know if the new driver solved it, or if rebuilding the old driver would have been sufficient (I am guessing that it would have been).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.