Java applets don't work at all (not detected by browser) if IE is launched normally. I'm currently using the latest version of Java 7u60 with Internet Explorer 11 on Windows 8.1. This issue seemed to have popped up randomly as the websites I've been using have just stopped running the Java app. Finally, it works fine in Chrome.

Have already tried reinstalling as administrator with both older version, but the issue still occurs.

Edit: A fresh reinstall of Java 7u67 did not fix the issue.

  • Have you checked your Java security level settings in Control Panel > Java? As of Java 7u51, the security is very strict by default, but you can adjust a slider. Java 7u60 allows for whitelisting to allow applets to run at given sites. – Debra Jun 21 '14 at 3:20
  • Yup, the slider is currently set at the lowest. I've also added the domain of the site I'm trying to access under Java's Exception Site List, so it is definitely not a security issue causing the applet to not run. – calvin Jun 23 '14 at 16:09
  • Can you create new non-admin account and try to run your applet on that account? If it runs - something is messed up in your IE profile files and its not about admin account, problem is in your account (C:\Users\Account\...\Internet Explorer or in user IE registry). – Kamil Aug 18 '14 at 23:27
  • In my observation adding a whitelisted domain in the Java exceptions site list such as http://domain.com will only whitelist that exact URL while adding it with a trailing slash, ie http://domain.com/ will whitelist all pages under that domain. – ccpizza Nov 3 '16 at 6:14

following worked for me:

  1. uninstall java using java remover (available at java.com)
  2. use total commander to find java at C (system drive) drive
  3. delete all those java folders in c:\users etc.
  4. reinstall java
|improve this answer|||||

Perhaps you're way ahead of me here but have you tried and/or verifyied the following:

  • Try installing both the 32-bit and 64-bit java versions (available through offline installers).

This helped me with incompatible add-ins messages

  • Adding the website URL to the site list on the Java control panel.

This helped me with some non working Java applets that didn't give me a warning or any notification

  • Set the default internet explorer settings for the internet security zone.

This helped me with some other non working Java applets that didn't give me a warning or any notification

|improve this answer|||||

We have been having similar issues on several Win7 IE10 PCs with Java 7.60. Reinstalling Java fixes it, but it is not clear why it stops being detected by IE. Very annoying in a business environment. I'll have to test next time if it works in another browser.

|improve this answer|||||

This will delete your profile. So you need to backup emails, Documents, your desktop, music, pictures etc!

  1. Login as Administrator
  2. Backup or copy your documents and settings (C:\Users\yourusername)
  3. Open registry editor and go to [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList] and expand
  4. Find your account name, right click and then delete
  5. Log off administrator account and then log back on to your normal account

Java should now run normally

|improve this answer|||||
  • 2
    Why would this solve the issue in the question? – Jan Doggen Jul 28 '14 at 9:21
  • 1
    Caveman method, too destructive. I don't like it. – Kamil Aug 18 '14 at 23:32
  • Better off reinstalling Windows. – oldmud0 Aug 2 '15 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.