I have an ASUS AX-112W Voip box behind a router, connected to a regular phone. After hours fighting with the router and the voip box, I finally found a configuration where everything works almost perfectly.

Except for the caller ID that simply does not works.

I have tried this with a crappy Siemens Gigaset C1 phone and with a brand new Philips CD560 phone. Depending on the type of CallerID I choose on the AX112W configuration I see EXTERNAL CALLER, NOT AVAILABLE or UNKOWN NUMBER when someone calls. If I connect the phone directly to the line, everything works.

The caller ID information is being lost inside the AX112W. Is this something related to the router? Some port being blocked? The router is a D-Link DSL-524T. My SIP provider is voipfone.co.uk.

What ports should I forward in the router and/or Asus box? Any other things I should check?

AX112W has this options for CallerID

  • US
  • Japanese
  • ETSI FSK during ring
  • ETSI FSK before ring
  • ETSI FSK no ring
  • ETSI DTMF during ring
  • ETSI DTMF before ring
  • ETSI DTMF no ring

I live in Portugal and I am not sure what system of CallerID is used here, but I have tried all these options of the AX112W without success. I had another SIP box before this, a Zoom X5V that worked perfectly.

The following pictures show the configurations I have here on the SIP section of AX112W


alt text

alt text

alt text

The Zoom x5v I had before this AX112W worked perfectly, not only showing the caller ID from calls originated on VOIP but also from call originated on POTS.


I am not sure if Gigaset C1 works with both DTMF and FSK modulations. You may need to switch between them in your AX-112W config and see what works.

Try to connect another Caller ID capable device, to make sure that you get Caller ID data from your AX-112W at all (if you do, then might be an incompatibility between AX-112W and Gigaset C1).

  • I have bought a new brand phone today. Same problem. The callerID data is being altered or removed by the AX112W. If I connect the phone to the wall, I see the ID working, but not when I connect it to the AX112W. I have edited the post to include some pictures that may help. Thanks for the help. – SpaceDog Dec 4 '09 at 6:11
  • Then try the two ETSI (European Telecommunications Standards Institute) standards, preferably those that say "during ring", as I have no idea what it's used in Portugal. Is it possible to see what setting Zoom x5v was using? The D-Link should be innocent because if you are able to speak, then you should also be able to get Caller ID. Tell me how it goes. – Saxtus Dec 4 '09 at 9:48
  • thanks. The zoom x5v says CID V23... I think it is referring to ITU-T V 2.3, I think, but this setting is not present on AW112W. After squeezing google in all directions I found someone mentioning that Portugal uses ETSI DTMF during ring. I have adjusted AW112W for that choice and still get no caller ID. Another strange thing happened today. I remove the brand new phone and put the crappy Siemens Gigaset C1 again and cleaned all its internal memories and logs and now this is happening... (continues on the next comment) – SpaceDog Dec 4 '09 at 11:14
  • (continuing...) I configured my iPhone using FRING, to use voipfone.co.uk with another SIP account of mine and used this to call the phone. AX112W is a wifi router as well and the iphone is connected to the web using it. Now, when I ring the phone using the iPhone the phone shows UNKNOWN for half a second then it shows the correct callerID. Any other calls from voip or from the regular phone line is shown as "external call". At this point the AX112W is adjusted to use ETSI FSK during ring. Voipfone say that they do not use any of the formats I mentioned. They say CID is sent as a SIP message. – SpaceDog Dec 4 '09 at 11:26
  • Well, yes... CID of course it's send as SIP message. A message that AX112W should translate to ETSI format so the Gigaset (that doesn't know what SIP is!) can show up the CID info. From what you're saying, AX112W passes CID info successfully (it is supposed to pass CID after the first ring, thus why it first shows UNKNOWN before CID arrives). From what you're telling, AX112W works fine now. Now you need to make sure that Voda sends actual CID to you. Try using a softphone and see if it shows CID. I would recommend X-Lite: j.mp/4J68PB . If it also fail to show CID, then blame Voda! – Saxtus Dec 4 '09 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.