Installed Linux as a dual-boot next to Windows 7 on my netbook and the install completed without any errors. When I pick the installed kernel from GRUB, I either get a blank screen with a blinking cursor (and hangs in there indefinitely) or the computer just restarts (loads BIOS again and goes back to GRUB). Thus I have a totally fresh install, as I haven't been able to load it up even once after installation. Picking Windows from GRUB or loading a LiveUSB session from a USB stick work just fine though.

There was a similar'ish bug report, but in my case even the recovery mode doesn't work. I've tried all sorts of combinations of the different options for loading up the kernel from the command line (leaving out splash, quiet, ro, all of the above, etc.), but none of them do any good.

So, does anyone know what could be going on or how I can troubleshoot the issue?

P.S. Since someone is bound to ask, the distro is Ubuntu Netbook Remix 9.10 and it uses GRUB2 (version 1.97), but I fail to see how that makes any difference, since it can't even load the generic linux kernel.

Edit: I checked the log files on the system, both dmesg and boot.log are empty, syslog hasn't even been generated yet. So, it really isn't getting anywhere. Would this make it a Grub issue?

Edit 2: Computer model is Samsung N510.


You don't say what make and model of netbook you have. That would help.

There may be a kernel boot option you need to add (rather than remove) - for example adding noapic or something similar. Hard to say without knowing what hardware you're running.

  • Ah yes, good point. – t0mppa Dec 4 '09 at 6:01
  • 1
    Well, I tried noapic and it got rid of the instant boot feature, leaving just the freezing there on a black screen and blinking cursor. Also tested acpi=off, that was reported fixing a problem with earlier 2.6 series kernels, but that had no effect on 2.6.31-14 anymore. – t0mppa Dec 4 '09 at 9:01

Boot from a Live-System and check your GRUB installation, configuration and disk layout. This sounds a little like it's messed up and GRUB is trying to start a wrong partition.

  • GRUB installation worked correctly and trust me, I tried different configurations about a hundred times, so tested the disk layout rather thoroughly. In the end the only thing I could think of was to install an older version of Ubuntu, running a 2.6.28 kernel instead of the 2.6.31 and that has worked just fine so far. – t0mppa Feb 5 '10 at 1:00

I have a Samsung netbook. It did the same thing to me. Well not exactly. I installed Ubuntu fine with a dual boot of windows xp. Now the problem is that some how the manufacturers put a 3rd hidden boot of windows vista.

my girlfriend got onto my pc and tried to boot the windows Vista partition and completely screwed it, now I have the same error. The only way that I know how to fix it is if you put Ubuntu back onto your usb, then change your bios to boot from usb first. Ubuntu will boot this time fine; but you have to re-install it.

One trick I recommend is that when you first finish installing Ubuntu make sure you download and install all updates that come with Ububtu and install all driver packages.

One thing that I have been trying to figure out also, when my netbook boots it tries to load the Grub boot menu to select which partition I want to boot. O wonder if there is a 3rd party tool that i can use that I can use to select which partition I can use. That way even if the ubuntu partition borks you can still use the windows partition. If all else fails put get yourself a hirens boot cd :) and put that onto your keystick and either fix or remove the whole ubuntu partition. That's all that I can really reconmend :) if that fails.... i cant help :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.