9

I have had a surface pro for a while now and I have decided to try and boot from USB on it. It won't boot from it.

I have tried an external hardrive with Windows Vista on, a Windows 98 Microsoft-dos boot disk and even a Windows repair disk on an external disk drive. All of these devices boot on everyone of my computers except my surface.

I have tried disabling secure boot keys in the BIOS and I have tried booting via Windows 8 advances options and by holding down the bottom volume rocker at start up. None of it works.

5
  • Can you boot Windows-on-the-Go (or whatever its called). The image should be signed, so the UEFI should list it as a boot option. – jww Jun 21 '14 at 14:01
  • We have this issue with Samsung Win 8 Pro tablets and (following exact same steps) have been unable to boot to USB. We've tried to contact Samsung but I'm not expecting a helpful response because we're doing non-standard setups. I'm wondering if the tablets have some additional hardware fingerprint checking so that it's as difficult as possible to change boot options... – Kinnectus Jun 21 '14 at 14:26
  • You will also need to use 64-Bit UEFI capable bootloaders - try a 64-Bit UEFI Ubuntu on your USB. – Kinnectus Jun 21 '14 at 14:32
  • ? Windows on the go? I disabled secure boot in the UEFI so it should work. – Luke Polanowski Jun 26 '14 at 19:10
  • Yes I used a 64 bit windows 7 recovery disk, 32 bit Windows vista OS and even a windows 98 ms-dos boot disk! – Luke Polanowski Jun 26 '14 at 19:12
4

http://blogs.technet.com/b/askcore/archive/2013/03/20/creating-bootable-usb-drive-for-uefi-computers.aspx

UEFI based systems such as the Surface Pro or other UEFI systems require that the boot files reside on FAT32 partition. If they are not FAT32 the system may not see the device as bootable.

Note Surface Pro only supports 64bit windows, so it's possible only a 64bit windows repair disk will work. Note the Windows USB/DVD Download Tool formats the drive with NTFS, instead use Rufus so you can format the drive with FAT32.

3

I Had the problem with a surface pro 4 after cleaning partitions with AOMEI Partition Assistant. It wouldn't load windows 10 or boot back to the USB partitioning tool I fixed mine with the following:

I used the surface pro's port replicator with a USB keyboard and mouse plugged in as the surface keyboard inst recognised. A recent copy of Ubuntu http://www.ubuntu.com/download/desktop A copy of Rufus to build the USB drive https://rufus.akeo.ie/

I turned off secure boot, TPM and set the USB service to be first in the boot order. I'm not sure if these steps are necessary but I did them before I fixed it.

Use Rufus to turn the ISO into a UEFI USB install (ensure Partition scheme and target type is set to GPT Partision scheme for UEFI) Boot with ubuntu USB drive plugged into the surface. Install Ubuntu taking over entire disk!

After the install, shut down the surface, reset the UEFI settings for TPM, Secure boot etc..

Boot from your UEFI windows installation / recovery media and reinstall Took me best part of four hours with many Linux distros, versions of windows, even more frustration and swearing.

Hopefully this helps someone!

1
  • I'm going through the same issues / working on the same resolution. So far your solution is getting me farther than I was getting on my own using YUMI for a USB boot! Thanks – schizoid04 May 22 '17 at 2:34
1

Instead of dealing with the UEFI boot issues with NTFS flash drives, just boot into advanced settings -> Command Prompt.

Then, go to your USB drive and install via the command prompt.

For example, with installing windows 10 from the flash drive, boot into the command prompt and then put in:

D:\setup.exe

D:\ is the flash drive.

After that, you will see the installer start.

0

I can confirm that with the Surface Book 1, some USB 3.0 drives won't boot unless they're in USB 2.0 mode. Old cables or hubs without the additional 3.0 pins will force the drive back into 2.0 mode, making it bootable.

In my case, a Team X101 32GB USB 3.0 worked while a Samsung Fit Plus 3.1 GB 256GB did not. Using an old USB 2.0 cable, the Samsung Fit Plus will boot. I've even managed to use a small piece of paper to cover up the back pins and force USB 2.0 without the cable (not recommended).

Note, the ports are USB 3.0 capable, but there seems to be a bug preventing certain drives from booting, possible a firmware bug.

Not the answer you're looking for? Browse other questions tagged or ask your own question.