5

I assembled a Windows 7 machine a few weeks ago, and now I noticed my download speeds are abysmal. Copying to this computer is about 150kbyte/sec, on a Gigabit LAN. Copying from it is fine.

  • It is not an ISP issue, as LAN copy speeds have the same problem
  • It is not a cable problem, the speed is the same on any cable
  • It is not a router issue, because the other computers on the LAN have no similar problems, and I even changed the socket this computer is plugged into on the router
  • It is not tied to a specific application, torrent, ftp and browser downloads are equally slow
  • It is probably a driver issue, because after reinstalling the Ethernet driver the download speed went up to 500kbyte/sec for half a day
  • Setting manual speed negotiation did not help either
  • Installing Win 8.1 clean (not just upgrade) did not solve the issue

The NIC is a Realtek PCIe GBE Family Controller according to the Device Manager. It came with the Asrock AM1B-ITX motherboard. The drivers were provided with the motherboard, but I tried the default Windows ones and and the latest from AMD.

Update2: *I just loaded Puppy linux, and the copy speeds were great were great for the first half hour. After that, the same behavior.

  • 1
    Perhaps the cable or connectors are faulty? – mtak Jun 22 '14 at 18:15
  • Sorry, I forgot to write that I tried that as well. – András Jun 22 '14 at 18:18
  • It doesn't look like a driver problem. What about malware? Or maybe someone is downloading on another PC? – Searush Jun 22 '14 at 18:21
  • Malware is possible, what is the best way to check? – András Jun 22 '14 at 18:48
  • 1
    Right-click on the Local Area Connection device in Control Panel > Network and Internet > Network Connections. Go to Properties. Click Configure. Go to Advanced tab. Look for "Speed and Duplex" – Sionide Jun 27 '14 at 2:29
1

Right-click on the Local Area Connection device in Control Panel > Network and Internet > Network Connections.

Go to Properties, click Configure. Go to the Advanced tab.

Look for "Speed and Duplex" Experiment with different values. As Jakke points point, "Auto" on this screen can sometimes go wrong. It may be some other setting on this Advanced tab needs tweaking.

0

It was an unspecified hardware issue, the retailer returned my mony after sending the motherboard back to the manufacturer for investigation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.