4

I am trying to install Google Chrome 35 on my CentOS 6.5 . After googleing for few hours I found that Google has decided not to support EL 6 release anymore. Due to which I get following error.

Error: Package: google-chrome-stable-35.0.1916.153-1.x86_64 (google-chrome) Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)

As default libstdc++.so.6.0.13 comes with OS and the latest being gcc 4.9 and libstdc++.so.6.0.20. I downloaded latest gcc source to build. It was built successfully and I tested the out put. but

gcc --version

returns 4.4.7. I checked my install directory which i set while doing configure was /usr/bin/gcc49/bin/gcc . when I ran same command here it was showing 4.9. I suppose this means that libstdc++ latest version is also complied and built as part of the process.

My problem now is after getting latest build of gcc google chrome still points to old version. is there a simple way to point rpm dependency checker to point to specific directory to install.

Thanks

  • This error is while installing the package using RPM ? Did you tried with Yum ? – lmedinas Jun 23 '14 at 15:20
  • I have tried installing using both YUM and RPM. Same issue comes – Chintan Shah Jun 26 '14 at 15:59
5

Did you try this? http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/

This worked for me. This links shows how to fix the problem installing Chrome in CentOS. You just need to download a script written by someone which will install all dependencies with chrome on CentOS.

Cheers

  • I am following this guide (using Lloyd's script) and Chrome is installing fine. But when I try to open it I get a Illegal instruction message. Any idea why? – makeMonday Jan 13 '15 at 16:35
  • 1
    @7SpecialGems Perhaps too late, but I posted all the pertinent info as a new answer. (The script is too big to be posted in its entirety.) – Michael Kropat Feb 16 '15 at 21:16
3

Per 7SpecialGems' request, I'm posting all the details on to this site:

The Google Chrome team no longer officially supports CentOS 6. That doesn't mean it won't work, however. Richard Lloyd has put together a script that does everything necessary to get it running:

wget http://chrome.richardlloyd.org.uk/install_chrome.sh
sudo bash install_chrome.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.