It's not specifically me, but rather my friend who cannot connect to our university's wireless. It's specifically something with that computer, because my computer, which is also Windows 7, connects fine to the same network. What's more interesting is that the other computer was able to connect a week ago - it kept up its ongoing connection for about a week, and when the computer shut down last night, it was no longer able to reconnect.

The authentication on my friend's user/password fails, even though the password hasn't changed, and we are using the same one that worked last week (Furthermore, the user/pass I use on my laptop to connect doesn't work on her computer). The ethernet cable which also works on my computer, gets stuck in an "unidentified network" state when used on hers.

She is running Windows 7. I have tried restarting, holding the power button to reset motherboard, and I've made sure it acquires IP and DNS information automatically (enable DHCP I believe it was called). I've also tried uninstalling the ethernet driver, and then restarting. It did reinstall the driver, but still no luck on getting past the unidentified network problem.

Any suggestions? Note: I cannot reset the router, because I do not have access to it. Note2: Her computer has chinese as its default language, so any error messages/information you'd need would likely have to come from command line. The one error I got from running Windows diagnostic test on the ethernet cable translated roughly to: "Local Area Connection Does not have a valid IP config".

It doesn't matter which one works, as long as one of them can be fixed - I'm perfectly ok with it being either ethernet or wireless, as long as internet can be achieved in some way.

Thanks in advance for any help.

  • You could run wireshark on your computer and her computer for clues as to differences in how you are each logging on. I haven't used wireless on win7 much, but on XP one would often get the list of wireless network accounts on the computer, and delete them all, then it'd try fresh. – barlop Jun 22 '14 at 19:40
  • 1
    Delete and re-add the wireless profile through her Win 7 Network and Sharing Centre. Also check the date and time on the machine is correct for your locale. Any network certificates for PEAP will require the clock be correct. Is this network "eduroam" by any chance? – Kinnectus Jun 22 '14 at 21:06

Try running this command in your command prompt (Win+R and type CMD):

ipconfig /release

ipconfig /renew

Also, it's worth mentioning that the 'diagnose' feature for Windows is actually quite good, unlike most of their Help facilities; try connecting an ethernet wire and right-clicking the network icon, selecting 'Troubleshoot Problems' (not sure of Chinese equivalent but it's the top of the two options on Windows 8.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.