11

Is there a simple and permanent way to disable the Microsoft Virtual WiFi Miniport Adapter permanently.

I believe this device may be the source of some wifi problems my users have been having.

10

AFAIK, the Microsoft Virtual WiFi Miniport Adapter is a virtual adaptor for sharing your internet connection (ie. making a wifi hotspot, or 'hosted network').

To disable this, open an elevated command prompt (cmd as admin) and type in the following commands, in order:

netsh wlan stop hostednetwork This stops the hosted network

netsh wlan set hostednetwork mode=disallow This disables the hotspot.

Source for commands

This worked for me and removed the adaptor on my computer.

  • This works only temporarily. The Miniport Adapters reappear after some time (reboot?). – Alph.Dev Aug 5 '15 at 12:40
  • Shouldn't do - it never came back for me... @Alph.Dev :/ – ᔕᖺᘎᕊ Aug 5 '15 at 12:50
  • 1
    I ran these commantds 3 times already. Every time it works. But when I experience wifi problems I visit Control panel > Network connections, and yep, there they are again. 2 Microsoft Virtual WiFi Miniport Adapters. – Alph.Dev Aug 5 '15 at 12:55
  • If you can see the adapters in Device Manager, can you delete them? – ᔕᖺᘎᕊ Aug 5 '15 at 12:55
  • 1
    It's worth mentioning that netsh wlan show hostednetwork will let you see if this feature is turned on in the first place. If it is, then the Mode: will be set to Allowed. – GuitarPicker May 3 '17 at 19:26
0

This virtual adapter was installed by my Intel Wireless driver software. I was unable to disconnect my main Network Interface Card driver from this virtual adapter software. So I just disabled the virtual adapter from the network connections window.

Right-click->disable

enter image description here

0

To permanent deletion of the hosted network adapter (Microsoft Virtual WiFi Miniport Adapter) just delete in windows registers this key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Wlansvc\Parameters\HostedNetworkSettings\HostedNetworkSettings

0

look up device manager> view (on the top bar)> view hidden devices> network adapters(in the main area)> find microsoft virtual adapter> right click disable.

enter image description here

-2

nope u need to look up device manager>view hidden devices(at the top)> on the main screen under network adapter find the microsoft virtual adapters > right click disable

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.