3

I am running Arch on VMWare and I am unable to find a WiFi interface.

When I run ip link I get: enter image description here

When I try to ping www.google.com it says that it is an unknown host but when I ping 0.0.0.0 I get a response.

I have the Google DNS Servers on my resolv.conf file right now 8.8.8.8 8.8.4.4

And that makes no difference from not even having a nameserver on there.

I have wifi on the VMWare instance, when I go to Network Adapter on the VMWare Player it shows me that it is good to go. I'm not sure what else to check. I am not wired yet I am able to ping IP addresses yet no wireless interface is showing.

Any advice?

  • 1
    Are you specifically trying to terminate a WiFi link on the guest for some reason? Normally, a virtual machine wouldn't have a WiFi link because virtual machines only have virtual devices and the WiFi link is physical. How are you expecting the virtual machine to have a WiFi interface? USB passthrough? – David Schwartz Jun 24 '14 at 3:13
  • 1
    David is right. The only way you will have a wifi interface on the vm is usb-passthru, which does work. Otherwise, if you want to share your host wifi with the vm, look at nat or bridged nets in vmware. If you are trying to see more info on what the vm detects as interfaces, try looking through 'dmesg' – glallen Jun 24 '14 at 4:10
  • So I should just try to access it like it is a wired connection? I have it under Bridged (Wi-Fi). And dmseg gives me a unreadably large amount of output. Any ideas on what to grep from it? – clifgray Jun 24 '14 at 4:54
  • The solution was that I couldn't get wifi on my VM I could only get ethernet. I just didn't realize there was the limitation but my Mac's wifi went through as ethernet on the VM and then it worked just fine. – clifgray Jun 29 '14 at 2:29
2

Run ls /proc/sys/net/ipv4/conf and you will see some variation of: all default eth0 lo wlan0. You can grep for these same interfaces in dmesg for more information regarding what your kernel/modules see regarding your hardware.

If all you see is all, default, eth0 and lo. Then you do not have a wlan0 device loaded regardless of vm or hardware system. By loaded, I mean it exists, and the kernel modules are loaded for it. If you see an ethX interface, that is your wired network interface. You will configure this as if you were configuring a normal wired ethernet port. For instance, for eth0, to first check the IP:

ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:11:22:33:44:55 brd ff:ff:ff:ff:ff:ff
inet 172.20.50.94/20 brd 172.20.63.255 scope global eth0
   valid_lft forever preferred_lft forever

If you do not see state UP you will need to run ip link set dev eth0 up

If no address is visible, then either configure according to you distro's documentation, configure with DHCP, dhclient eth0 or configure the ip address and route manually. Since you are using a bridged virtual interface to wifi, you should only need to use DHCP, and your wifi router will provide an address.

To manually configure and interface however, you would do this:

ip address add <address>/<cidr> dev eth0
ip route add default dev eth0
echo "nameserver <dns-ip>" > /etc/resolv.conf

And verify with:

ip address show
ip route show
dig <domain name>

For additional assistance, see the man-pages for ip resolv.conf

  • Hey thanks for the great response. I wrote a quick comment above explaining how to fix it up then used some of your steps to verify so I marked it correct. – clifgray Jun 29 '14 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.