1

I installed VirtualBox on CentOS 6.0. Installed Windows 7 as a guest OS. Now it doesnt recognize the network card in the guest OS even after I installed guest additions. The network mode is NAT. Previously I tried bridged mode but that didn't work either. How do I resolve this?

vm info:

[root@sn ~]# VBoxManage showvminfo testvm
Name:            testvm
Groups:          /
Guest OS:        Windows 7 (64 bit)
UUID:            ef2de77b-67ba-42f9-b2f6-8a1a3a5c8adb
Config file:     /root/VirtualBox VMs/testvm/testvm.vbox
Snapshot folder: /root/VirtualBox VMs/testvm/Snapshots
Log folder:      /root/VirtualBox VMs/testvm/Logs
Hardware UUID:   ef2de77b-67ba-42f9-b2f6-8a1a3a5c8adb
Memory size:     1024MB
Page Fusion:     off
VRAM size:       8MB
CPU exec cap:    100%
HPET:            off
Chipset:         piix3
Firmware:        BIOS
Number of CPUs:  1
PAE:             on
Long Mode:       on
Synthetic CPU:   off
CPUID overrides: None
Boot menu mode:  message and menu
Boot Device (1): DVD
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI:            on
IOAPIC:          on
Time offset:     0ms
RTC:             local time
Hardw. virt.ext: on
Nested Paging:   on
Large Pages:     off
VT-x VPID:       on
VT-x unr. exec.: on
State:           powered off (since 2014-06-25T00:44:24.000000000)
Monitor count:   1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address: 
Teleporter Password: 
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration: 
Autostart Enabled: off
Autostart Delay: 0
Default Frontend: 
Storage Controller Name (0):            IDE Controller
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
IDE Controller (0, 0): /root/VirtualBox VMs/testvm/testvm-disk03.vdi (UUID: ec572cb1-fc24-40da-a581-46f6eb4fe411)
IDE Controller (0, 1): /usr/share/virtualbox/VBoxGuestAdditions.iso (UUID: a30bd107-b2d9-48cc-b232-7bf2a4372389)
IDE Controller (1, 0): /tmp/win7.iso (UUID: a4e22aa8-fa5e-4dc6-8f41-e82377affeac)
NIC 1:           MAC: 080027CCF2B3, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1:          disabled
UART 2:          disabled
LPT 1:           disabled
LPT 2:           disabled
Audio:           disabled
Clipboard Mode:  disabled
Drag'n'drop Mode: disabled
VRDE:            disabled
USB:             disabled
EHCI:            disabled

USB Device Filters:

<none>

Available remote USB devices:

<none>

Currently Attached USB Devices:

<none>

Bandwidth groups:  <none>

Shared folders:  <none>

VRDE Connection:    not active
Clients so far:     0

Video capturing:    not active
Capture screens:    0
Capture file:       /root/VirtualBox VMs/testvm/testvm.webm
Capture dimensions: 1024x768
Capture rate:       512 kbps
Capture FPS:        25

Guest:

Configured memory balloon size:      0 MB

enter image description here

  • File a bug report. – user35787 Jun 25 '14 at 6:10
  • Still seeing this issue... – Freedom_Ben Aug 9 '14 at 18:17
-1

I've spent 1 day, trying anything, manytimes unistall & install again (with reboot system). I have tried tens of methods, nothing can help me. Also I've tried to install drivers pack. I've tried to install different version (even beta)... Don't like Hyper-V, never had same problems with Hyper-V... nonsence...

Added (Fixed!): Wow, finally I've fixed it, you know how? Before I've tried to choose different ethernet NICs from the list in network configuration of machine in VirtualBox - nothing could help me. I've just installed 6.0.12 version (the last was 6.0.14), and fixed it even without reboot. What I did: I downloaded Full pack of ethernet-drivers (you can find it in google drp dot su), but didn't run it! just unpack everything from folder "drivers", then update drivers in Drivers Manager, by choose second option: Others-Ethernet-controller(unknown device) and choose manual where to find for drivers... That's it. I've tried to do same in others version ov VirtualBox (it didn't help me, also don't install version 5.0 it will not work). Also before these manipulations I've changed NIC, to pcnet fast III & intel pro/1000 MT server. But if you only change it, it will not help...

Also don't forget to install new version of Extension pack for your version of VirtualBox. And don't use Portable version of VirtualBox, it will not work work correctly for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy