I have some trouble with languages in my Windows 8.1. I can't tell when it happened (what could i do in this time), but right after installing os and maybe a few week after it was okay. But not now.

So, my problem is:
I use two language Russian and English (US) (US by default). And after rebooting computer I saw that it's no lang button on the taskbar (next to tray), and It's Russian now and I can't change language (I tried a few different cases). I remove Russian one in list via control panel, and nothing happen (absolutely!). I tried to add some different languages and remove them - nothing!

After all, I remove all languages except English and reboot computer again. After that I saw a normal behavior and English by default (it's no lang button next to tray, but it's normal because it's only one language in system). I tried to add Russian one. It worked, russian was added successfully, I saw lang button and I can change keyboard language with keys combination. BUT it's not happy end. I remove Russian one again, and saw it: enter image description here
I have only one language in list, but it's two of them in system! And I can change language and use them by normal (before rebooting).
And one more thing: when I have 2 languages before rebooting, then after it I have Russian one by default and it blocked (I can't change anything, I have to reboot). So the same thing as in beginning of story.

By the truth, I have another windows 8.1 on my laptop and I haven't seen the same behavior. It's the same combination of soft I installed. I install a lot of systems (start with windows 98) and I never have seen this problem.

After googling, I see that maybe it's a problem with my register. Maybe something can block it, so I have this behavior. But I don't what is it...

Any ideas?

P.S. Please, don't tell me use one language, or remove russian one before reboot, and add it after (I do this now:). It isn't the solution of my problem.

The lanaguages on the Taskbar shows the input languages i.e The Computer has enable US and Russian Keyboard layouts. Whet the two languages were installed, The russuian keyboard was enabled by default.

A simple fix is to delete the russian Keyboard from the Control Panel

up vote 0 down vote accepted

I still don't know what the problem was, but now after updating system (I didn't note which one helps) this problem disappeared. Everything is back to usual work. Magic.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.