2

We have a server running Windows Server 2008. The server is the file share server.

Shadow copies look to have been set up previously, but now it isn't working at all.

Upon right-clicking on the drive and going to "Configure Shadow Copies", The error message is all that is displayed.

enter image description here

When trying to view the previous versions from a Users PC, it searches and finds nothing.

The Volume Shadow Copy service is running.

I have looked at the registry key permissions and followed those instructions but hasn't worked.

0

Did you try doing this?

To restart the Volume Shadow Copy service and SPP services

You must be logged on as an administrator to perform these steps.

  1. Open Administrative Tools by clicking the Start button, clicking Control Panel, clicking System and Maintenance, and then clicking Administrative Tools.

  2. Double-click Services. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. If the SPP or the "Microsoft Software Shadow Copy Provider" service is disabled, double-click it to open the service properties.

  4. If Volume Shadow Copy service is double-click it to open the service properties

  5. Click the Startup type list, click Automatic (Delayed Start), and then click Apply.

  6. Under Service status, click Start.

1
  • Yes have tried this too but still had the same issue.
    – Joey
    Jul 28 '14 at 10:03
0

Server hadn't been restarted in over a year. After a few restarts, the VSS is working again.

1
  • 1
    Seems like a restart fixes almost everything. Glad to see your problem is solved. Jul 29 '14 at 1:07
0

While reboot usually helps for most of this problems and there are multiple reasons for this I've finally decided to track down this problem in my own backyard that was usually fixed by reboot but kept coming back..

In my case it was problem with VeraCrypt. One has to make sure that encrypted external drives are mounted as Removable. Use Mount volume as removable medium when attaching encrypted drive.

Full story can be found in my blog post The shadow copy provider had an unexpected error while trying to process the specified command.

Veracrypt

0

MadBoy answer fixed it, thanks.

Additionally those having this related issue can be helped with that answer:

Windows 2008 server

VMware vCenter Converter Standalone 6.1.1 build-3533064

Failed at 1%

Failed: Unable to create a VSS snapshot of the source volume(s). Error code: 2147754758 (0x80042306).

Microsoft Software Shadow Copy Provider service needs to be set to Automatic Startup Type and started.

Volume Shadow Copy service set to Automatic (Delayed) Startup Type and started.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.