1

I've installed Wamp Server 2.2, which includes php 5.3.13, Apache 2.2.22 and MySQL 5.5.24. Then I installed php 5.2.4 using the WampServer2-PHP524.exe extension found here on SourceForge.

When I switch to php 5.2.4 I get an error in phpMyAdmin telling me "#2005 - Unknown MySQL server host 'localhost:3307' (11001)" (I have XAMPP installed also at this point, so MySQL is set up on port 3307 for the WAMP install.)

I've tried a few different things based on various responses to similar problems:

Based on this answer, I copied php.ini from the php 5.2.4 directory into the Apache bin directory.

I tried changing the php.ini setting for mysql.default_port from blank to my port 3307

My phpMyAdmin config file has these settings:

$cfg['Servers'][$i]['verbose'] = 'localhost:3307';
$cfg['Servers'][$i]['host'] = 'localhost:3307';
$cfg['Servers'][$i]['port'] = '3307';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = _private_;
$cfg['Servers'][$i]['AllowNoPassword'] = true;

I've double checked my.ini to make sure my port settings are correct. It all works with php 5.3.13, so I really don't think it's anything to do with an errant port setting, though.

I tried changing the phpMyAdmin alias file to this, per a response to another question that I can't find now:

<Directory "c:/wamp/apps/phpmyadmin3.5.1/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
        Order Deny,Allow
    Allow from all
</Directory>

I've also verified that that directory is the correct directory for phpMyAdmin.

I've compared the php.ini file between 5.2.4 and 5.3.13 and I don't really see any differences between the two as far as how MySQL is set up.

Does php 5.2.4 require a different version or Apache and/or MySQL?

I'm trying to get this working so that I can ensure my WordPress plugins are compatible with WordPress's minimum requirements.

Oh, and, I doubt it needs to be said, but I did restart all services between each change.


This is the MySQL log.

140621  9:52:18 [Note] Plugin 'FEDERATED' is disabled.
140621  9:52:18 InnoDB: The InnoDB memory heap is disabled
140621  9:52:18 InnoDB: Mutexes and rw_locks use Windows interlocked functions
140621  9:52:18 InnoDB: Compressed tables use zlib 1.2.3
140621  9:52:18 InnoDB: Initializing buffer pool, size = 128.0M
140621  9:52:18 InnoDB: Completed initialization of buffer pool
140621  9:52:18 InnoDB: highest supported file format is Barracuda.
140621  9:52:18  InnoDB: Waiting for the background threads to start
140621  9:52:19 InnoDB: 1.1.8 started; log sequence number 1595675
140621  9:52:19 [Note] Server hostname (bind-address): '(null)'; port: 3307
140621  9:52:19 [Note]   - '(null)' resolves to '::';
140621  9:52:19 [Note]   - '(null)' resolves to '0.0.0.0';
140621  9:52:19 [Note] Server socket created on IP: '0.0.0.0'.
140621  9:52:19 [Note] Event Scheduler: Loaded 0 events
140621  9:52:19 [Note] wampmysqld: ready for connections.
Version: '5.5.24-log'  socket: ''  port: 3307  MySQL Community Server (GPL)

migrated from serverfault.com Jun 25 '14 at 15:18

This question came from our site for system and network administrators.

  • I don't understand: php 5.2.4 would fit the minimum reqs, but php 5.3.13 would not? Is there some extension in the former which isn't available in the later? – didierc Jun 21 '14 at 14:27
  • 1
    @didierc WordPress requires at least 5.2.4 and for the plugin to be fully compatible with WordPress it needs to be able to run on a server running 5.2.4. There are features in 5.3 that are not available in 5.2, so I feel it would be good to have a server running 5.2.4 for WordPress development, so that I don't accidentally write something incompatible. – MrsLannister Jun 21 '14 at 14:51
  • That makes sense. – didierc Jun 21 '14 at 14:53
  • Have you considered running a linux vm with the right setup? – didierc Jun 21 '14 at 14:54
  • Well, I used to use linux, but my new computer has windows 8, which has created a whole lot of problems as far as that is concerned. While I could setup virtualbox with a linux vm, it's not something I really want to do, mostly because this computer is crazy slow (seriously, never buy a Sony Vaio computer). I would rather get this working on windows. If I have to go the linux route I will. But I would like to figure out why WAMP Server isn't working right now. – MrsLannister Jun 21 '14 at 14:59
3

Host and Port are separate variables, you need to remove the port from the host variable.

Change:

$cfg['Servers'][$i]['host'] = 'localhost:3307';

to:

$cfg['Servers'][$i]['host'] = 'localhost';

From here

  • Thanks, that did it. Weird that it worked fine with php 5.3.13. – MrsLannister Jun 21 '14 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.