I am on Windows 8.1, Professional edition. I installed SQL Server Management Studio 2012 x64 and everything worked well. I installed Visual Studio 2013 and everything worked well.

Then, I installed Service Pack 1 for Visual Studio and some advanced features. I had trouble uninstalling these things, so I did a system restore to roll back my computer. That worked, but now whenever I go to SSMS, I get a

"Cannot find one or more components. Please reinstall application"

I tried repairing SSMS, uninstalling, reinstalling and even tried SSMS 2014, yet no matter what I do when I go to SSMS I still get that same error.

I am wondering if there is some component that is missing or was removed when I removed Visual Studio Pro? I re-installed Visual Studio 2013 express, and it works, but SSMS still won't work.

I looked at this post and deleted 11.0_Config from the registry, but still no luck.

I then deleted the entire SQL Server Management Studio registry and reinstalled and still no luck.


Every time I install SSMS 2012 or 2014 I get the same above error during the installation when it is installing ManagementToolsAdvancedConfig_install_postmsi_Cpu64. Yet, the installation continues and finishes and even shows all green checkmarks saying everything was installed...

Here is the log summary that was printed after the re-install. Not sure if this helps any:

Overall summary:
  Final result:                  Passed
  Exit code (Decimal):           0
  Start time:                    2014-06-26 12:10:28
  End time:                      2014-06-26 12:18:57
  Requested action:              Install

Machine Properties:
  Machine name:                  MYMACHINE
  Machine processor count:       8
  OS version:                    Windows 8
  OS service pack:               
  OS region:                     United States
  OS language:                   English (United States)
  OS architecture:               x64
  Process architecture:          64 Bit
  OS clustered:                  No

Product features discovered:
  Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered  Configured

Package properties:
  Description:                   Microsoft SQL Server 2014 
  ProductName:                   SQL Server 2014
  Type:                          RTM
  Version:                       12
  SPLevel:                       0
  Installation location:         C:\Users\ME\Downloads\SQLManagementStudio_x64_ENU\x64\setup\
  Installation edition:          Express

Product Update Status:
  None discovered.

User Input Settings:
  ACTION:                        Install
  AGTSVCACCOUNT:                 <empty>
  AGTSVCPASSWORD:                <empty>
  AGTSVCSTARTUPTYPE:             Manual
  ASBACKUPDIR:                   Backup
  ASCOLLATION:                   Latin1_General_CI_AS
  ASCONFIGDIR:                   Config
  ASDATADIR:                     Data
  ASLOGDIR:                      Log
  ASPROVIDERMSOLAP:              1
  ASSVCACCOUNT:                  <empty>
  ASSVCPASSWORD:                 <empty>
  ASSVCSTARTUPTYPE:              Automatic
  ASSYSADMINACCOUNTS:            <empty>
  ASTEMPDIR:                     Temp
  CLTCTLRNAME:                   <empty>
  CLTRESULTDIR:                  <empty>
  CLTSTARTUPTYPE:                0
  CLTSVCACCOUNT:                 <empty>
  CLTSVCPASSWORD:                <empty>
  CLTWORKINGDIR:                 <empty>
  COMMFABRICPORT:                0
  CTLRSTARTUPTYPE:               0
  CTLRSVCACCOUNT:                <empty>
  CTLRSVCPASSWORD:               <empty>
  CTLRUSERS:                     <empty>
  ENABLERANU:                    false
  ENU:                           true
  ERRORREPORTING:                false
  FEATURES:                      CONN, BC, SDK, SSMS, ADV_SSMS, SNAC_SDK
  FILESTREAMLEVEL:               0
  FILESTREAMSHARENAME:           <empty>
  FTSVCACCOUNT:                  <empty>
  FTSVCPASSWORD:                 <empty>
  HELP:                          false
  INDICATEPROGRESS:              false
  INSTALLSHAREDDIR:              C:\Program Files\Microsoft SQL Server\
  INSTALLSHAREDWOWDIR:           C:\Program Files (x86)\Microsoft SQL Server\
  INSTALLSQLDATADIR:             <empty>
  INSTANCEDIR:                   C:\Program Files\Microsoft SQL Server\
  INSTANCEID:                    <empty>
  INSTANCENAME:                  <empty>
  ISSVCACCOUNT:                  NT AUTHORITY\Network Service
  ISSVCPASSWORD:                 <empty>
  ISSVCSTARTUPTYPE:              Automatic
  MATRIXCMSERVERNAME:            <empty>
  MATRIXNAME:                    <empty>
  NPENABLED:                     0
  PID:                           *****
  QUIET:                         false
  QUIETSIMPLE:                   false
  ROLE:                          AllFeatures_WithDefaults
  RSINSTALLMODE:                 DefaultNativeMode
  RSSHPINSTALLMODE:              DefaultSharePointMode
  RSSVCACCOUNT:                  <empty>
  RSSVCPASSWORD:                 <empty>
  RSSVCSTARTUPTYPE:              Automatic
  SAPWD:                         <empty>
  SECURITYMODE:                  <empty>
  SQLBACKUPDIR:                  <empty>
  SQLCOLLATION:                  SQL_Latin1_General_CP1_CI_AS
  SQLSVCACCOUNT:                 <empty>
  SQLSVCPASSWORD:                <empty>
  SQLSVCSTARTUPTYPE:             Automatic
  SQLSYSADMINACCOUNTS:           <empty>
  SQLTEMPDBDIR:                  <empty>
  SQLTEMPDBLOGDIR:               <empty>
  SQLUSERDBDIR:                  <empty>
  SQLUSERDBLOGDIR:               <empty>
  SQMREPORTING:                  false
  TCPENABLED:                    0
  UIMODE:                        AutoAdvance
  UpdateEnabled:                 true
  UpdateSource:                  MU
  USEMICROSOFTUPDATE:            false
  X86:                           false

  Configuration file:            C:\Program Files\Microsoft SQL Server\120\Setup Bootstrap\Log\20140626_121025\ConfigurationFile.ini

Detailed results:
  Feature:                       Management Tools - Complete
  Status:                        Passed

  Feature:                       Client Tools Connectivity
  Status:                        Passed

  Feature:                       Client Tools SDK
  Status:                        Passed

  Feature:                       Client Tools Backwards Compatibility
  Status:                        Passed

  Feature:                       Management Tools - Basic
  Status:                        Passed

  Feature:                       SQL Client Connectivity
  Status:                        Passed

  Feature:                       SQL Client Connectivity SDK
  Status:                        Passed

  Feature:                       Setup Support Files
  Status:                        Passed

Rules with failures:

Global rules:

Scenario specific rules:

Rules report file:               C:\Program Files\Microsoft SQL Server\120\Setup Bootstrap\Log\20140626_121025\SystemConfigurationCheck_Report.htm

Is there some other way to look at a log or something to see what components are missing?

  • Have you tried removing the registry entry? Without knowing what components its missing its hard to instruct you how to solve it. Since its your computer the log file has to exist you just have to locate it.
    – Ramhound
    Jun 26, 2014 at 14:28
  • That is what I am also asking: where can I find this log file? --- as for removing that registry, is that safe to do?
    – Micro
    Jun 26, 2014 at 14:33
  • Considering its a non-system-critical entry its perfectly safe to do so. If you are really worried export the entry before you delete it. Here is a question that describe which entry should be deleted
    – Ramhound
    Jun 26, 2014 at 14:50
  • @ramhound, thanks for your help. Already seen that post. Deleted registry entry and re-installed, still same problem... Question updated with new info.
    – Micro
    Jun 26, 2014 at 16:20
  • FIXED IT! Won't let me post my own answer for another 8hrs tho...
    – Micro
    Jun 26, 2014 at 17:09

5 Answers 5


There is absolute no need to reinstall SSMS or VS. Just find the VS shell installer in the folder, where SSMS installer unpacks its files:


and install it.

  • 1
    Welcome to SuperUser. Your answer would be even better if you edit it to provide some explanation as to why your solution addresses the OPs question. Nov 25, 2014 at 20:16
  • 1
    SQL Server 2014 - I am getting an error when trying this technique. "To install this product, please run Setup.exe" Of course, that's the first thing I tried, but there's no repair option listed there.
    – Lucas
    Jul 21, 2015 at 13:26
  • 1
    Found it - Repair is tucked under Maintenance. That fixed the problem.
    – Lucas
    Jul 21, 2015 at 13:29
  • 1
    This answer put me on the right track, but this link was a better source for the shell installer: microsoft.com/en-ie/download/confirmation.aspx?id=1366 Dec 29, 2015 at 3:35
  • Where may I search for this VisualStudiosHell...?? Jan 5, 2016 at 20:40

Yahooo!! I fixed it!

I found this link and at the very bottom "Wael" wrote the following:

SSMS Depends on Visual Studio 2010 IDE, which if not installed the SQL Server Setup will do, but if any version is present, the setup will ignore it, even at repair

Re Install, I figured that the SSMS needs Visual Studio 10 IDE to run, which I've removed by mistake after uninstalling VS 2010.

So, I Opened the Setup Media and searched for Visual Studio Setup. The .msi file run quitly and Filled the missing parts, and the Management Studio Run OK.

So I uninstalled all SSMS, Visual Studio 2013, AND everything else that had "Visual Studio" in the name from program files (like the shell). Then, I re-installed SSMS and now it works.

  • Confirmed. After a SQL Server repair operation Visual Studio 2010 Prerequisites where re-installed. I wish there would be a warning when a user tries to uninstall a critical dependency for another piece of software. Sep 21, 2016 at 8:27

The above suggestions didn't work for me - I re-ran the Setup.Exe for SQL Server, and just chose the Repair option. Took 1 minute, and all was fixed.

  • This is actually the first time ever for me when following lots of sophisticated advice was of no use, but the Repair thing really did the job.
    – svz
    Jul 3, 2015 at 13:10
  • for me to. thanks! 1033_ENU_LP\redist\VisualStudioShell\VSSetup did not work for me.
    – ruedi
    Aug 13, 2015 at 12:54

Running F:\1033_ENU_LP\redist\VisualStudioShell\VSSetup\vs_setup.msi from SQL Server 2014 ISO solved this issue for me. Looks like the Visual Studio Shell was removed somehow before and that corrupted the SQL Server Management Studio as it depends on it. Strange that the SQL Server repair process didn't pick this up though


There solved it for me: From the SQL Server DVD (or ISO) Run this: D:\redist\VisualStudioShell\VS10sp1-KB983509.msp

This will detect other anomalies with regards your VS10 requirements and fix all as required.

I was able to launch my SSMS 2012 even part way through the fix.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .