15

I used to be able to pin Eclipse to my taskbar by adding these lines to the eclipse.ini file:

-vm
C:/Program Files/Java/[my java version]/bin

But it doesn't seem to work with the new Eclipse Luna release. Now, without those lines, I can't pin the application and, with them, the context menu doesn't even show up when I right-click the icon on the taskbar.

Is there any way to fix this?

3
  • I have the same issue. I searched bugs.eclipse.org but couldn't find any reference to the broken right-click menu. Pinning has been partially broken for several versions now (see bugs 314805 and 432353)
    – Didier L
    Jul 1, 2014 at 7:51
  • Personally I just pin it to the start menu so I only ever have one icon in the taskbar.
    – Enigma
    Jul 9, 2014 at 14:00
  • How about just dragging the eclipse.exe from Explorer to the taskbar? Sep 9, 2015 at 12:51

9 Answers 9

11

I have used the -vm setting in eclipse.ini in past versions, but it did not solve the issue here. Pinning to the Task Bar directly seemed to leave me with a duplicate icon once Luna finished initializing. FWIW, I seem to have hacked into a correction. First I right-clicked eclipse.exe and Pinned to the Start Menu. Then after starting Luna from Start, I right-clicked the icon which appeared on the Task Bar, and Pinnned to the TaskBar. Then I unpinned from the Start Menu (since I prefer direct access to the icon rather than Start > Eclipse). And once done, Luna now starts from the Task Bar and the icon is updated, but not duplicated, when fully loaded.

2
  • 3
    This worked for me after I put back the -vm in the ini file. Jul 10, 2014 at 16:38
  • this did not work for me. Adding the java bin folder to the front of the path variable did. Mar 4, 2015 at 15:58
7

Had this issue with Eclipse Mars 64 bits on Windows 10 Pro x64 Insider Preview Build 10130. The only way I managed to fix that is by executing Eclipse as it was a Windows Vista app:

  1. Remove any pinned icon to fom the taskbar

  2. Right click on the Eclipse executable -> Properties -> Compatibility tab -> Compatibility Mode

  3. Check Run this program in compatibility mode for

  4. Select Windows Vista (any of them).

  5. Execute Eclipse by clicking on the executable and pin it when it's fully loaded.

I didn't need to add the -vm flag in neither the shortcut (C:\Users\[Your User]\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar) or the eclipse.ini file.

5
  • although this had worked to get rid of the duplicate icon, I found that my git projects on JDK8 will get an internal error. The stack trace following this comment shows that it is triggered by jgit Jun 30, 2015 at 15:12
  • java.lang.InternalError: Should not get here at sun.nio.fs.WindowsNativeDispatcher.CreateSymbolicLink0(Native Method) at sun.nio.fs.WindowsNativeDispatcher.CreateSymbolicLink(WindowsNativeDispatcher.java:890) at sun.nio.fs.WindowsFileSystemProvider.createSymbolicLink(WindowsFileSystemProvider.java:578) at java.nio.file.Files.createSymbolicLink(Files.java:1043) at org.eclipse.jgit.util.FileUtil.createSymLink(FileUtil.java:111) Jun 30, 2015 at 15:13
  • Sorry to hear that! I cannot tell you if I have the same behavior on my side since I'm not using Eclipse for Java, although you should try adding the -vm flag in neither the shortcut (C:\Users[Your User]\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar) or the eclipse.ini file. You can find the exact procedure in many answer in this thread. Just be sure to add the line at the very beginning of the eclipse.ini file. Jul 2, 2015 at 0:48
  • Bug @ArchimedesTrajano described in not specific to java, but rather to egit. I'm having the same problem on win10 with php project, shared with git.
    – Cthulhu
    Sep 17, 2015 at 7:24
  • 1
    Neither adding the -vm parameter nor the trick with first pinning it to the Start menu worked for me, though changing the compatibility setting fixed the problem for me on Windows 10 + eclipse 4.6 (neon). May 28, 2016 at 10:45
2

The steps:

  1. Go to your eclipse installation directory, right click eclipse.exe and click "Create shortcut"
  2. Open Eclipse by double-clicking the newly created shortcut.
  3. Go past the workspace selection and the splash screen. Once Eclipse is fully loaded, right-click the Eclipse icon in the taskbar, and click "Pin this program to taskbar".
  4. Close Eclipse.
  5. Delete the shortcut.

The results:

  • No duplicate Eclipse taskbar entries, which is a known issue in the latest Eclipse releases
  • Context menu of Eclipse's taskbar entry works (I noticed this is a new issue in Eclipe Luna)

You have to make sure that Eclipse will run in a good JVM, too. You can therefore modify your PATH system variable to include the path to the JVM of your choice, or modify the eclipse.ini file in the same directory as eclipse.exe, and add the following 2 lines:

-vm
C:/Program Files/Java/[your Java VM]/bin

If you choose the PATH solution, you append to your PATH variable this piece of text:

;C:/Program Files/Java/[your Java VM]/bin

Ensure yourself that Eclipse is running in the JVM you chose, by opening Windows Task Manager and inspecting the command line used to run Eclipse. On my system, I noticed that some javaw.exe located in C:\Windows\System32\ was used, which was not what I wanted.

2
1

This worked for me:

1 - Copy / paste the executable "eclipse.exe" on the desktop 2 - Pinning to Taskbar 3 - Delete the desktop executable 4 - Right-click on the eclipse icon in the taskbar > right click on the eclipse icon in the list > Properties 5 - Change the path to the executable (target : ..../eclipse.exe) and change the directory (Start in:)

Strange but it works for me !!!

1
  • Does not work, you will end up with 2 icons in the taskbar.
    – Timmos
    Oct 15, 2014 at 12:07
0

Had the exact same problem today so the work around I am currently using is to locate the eclipse executable and right click it and say "Pin to taskbar." Clunky and non-uniform behavior to the most other windows applications, but maybe someone will have a better fix in the future.

2
  • 1
    This doesn't work, when Eclipse is fully started, it uses a new icon beside the pinned icon. Jul 9, 2014 at 13:51
  • Yeah I noticed that way later in the day. While the splash screen is up it looked perfect and I must have forgotten to check later. I'll check back in if I can get something working with it.
    – Randomh3r0
    Jul 10, 2014 at 12:45
0

I found out a way to make it work.

First, locate Eclipse.exe and pin it to your taskbar. Next, start eclipse using that pinned icon. Now you will see that once the splash screen is gone, eclipse is displayed in the taskbar as a separate icon from the one that you used to launch it.

Not to worry. Unpin the old icon, right click on the icon where eclipse is running and pin it. Voila! The icon will get pinned and eclipse will continue running. Now, close and start eclipse as needed and you will see that it works perfectly.

PS: do not forget to add -vm and specify the path of your JVM in eclipse.ini

1
  • 4
    This does not work with Eclipse Luna: the context menu is unavailable in the second icon that appears.
    – Timmos
    Oct 15, 2014 at 12:08
0

I just clicked and dragged the Eclipse icon to the taskbar. Pinned.

0

Adding this answer, as this superuser page shows up number 1 on Google for "eclipse luna cannot pin to taskbar"

What worked for me running Eclipse Luna 1a (4.4.1) on Windows 8:

Simply adding the bin folder to the path is not enough, I needed to specify the location to the bin/server/jvm.dll with the -vm parameter:

-vm C:/Program Files/Java/[myJavaVersion]/bin/server/jvm.dll

Also, it only worked if this line was added before the rows containing

 --launcher.appendVmargs [...]

There has been an eclipse bug report filed for this since 2010. The comments include helpful tips: https://bugs.eclipse.org/bugs/show_bug.cgi?id=314805

0

Previous answers did not work for me at all (Windows 7 64-bit)...

Adding the -vm entry to eclipse.ini caused Eclipse to fail to start: it just showed a big error dialog (and yes the entry did point to a valid Java VM).

Workarounds involving pinning to the start menu, or creating a shortcut on the desktop had no effect.

What did work was adding the Java bin directory (C:\Program Files\Java\jre7\bin) as the first item in my PATH (the PATH of System variables not the PATH in User variables). Having done this, I started Eclipse, waited for it to get past the splash screen, and right clicked on the taskbar entry. Now the "Pin this program to taskbar" does appear in the menu, and as an added bonus the "New Task" and "Activate Task" entries work too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .