2

From the surface, this is one of those questions about keyboard layouts from somebody who types a quote, then gets nothing, then types another letter and is surprised to get an accented letter :). I believe my problem is a bit more complicated so please bear with me.

I recently got a new laptop, and I use Windows 7 + the US-International keyboard layout. I intentionally use that one because I like the 'dead key' options:

' + a vowel becomes (á é í ó ú)
" + a vowel becomes (ä ë ï ö ü)
etc. etc.

This is very useful, in my own language I use them from time to time and I know a bit of Spanish and Italian :). However, I am also a programmer and I need the double and single quote on a regular basis. Previously, I was able to get that character by typing a space immediately after the 'dead key', and the regular single or double quote would appear. After that I could continue typing without any modification of the subsequent keys / letters.

However, currently (it's driving me nuts even as I'm typing this ;) ) the dead key modification appears to be not cancelled by hitting the space bar!

So I type

' + a          => I get á immediately - (this is ok)

' + space + a  => I get 'á - (this is not ok, I am expecting 'a :) )

' + space + b  => ''b - 
(this is also not ok, now I get two single quotes but I only typed one! 
However making the quote appear looks like the default behavior after 
typing a dead key + a consonant)

The dead key modification appears to 'work twice'!

One more example:

' + space + space + space + add as many spaces as you want + a
the last a still gets modified to á.

Does this sound familiar to anybody? I have no idea if all of this is determined only by the keyboard layout or whether there is something more in Windows that I can tweak?

I know that using the 'US' keyboard layout will make the quotes work normally (they stop modifying vowels), but with the US keyboard layout it's very difficult to make these accented letters!). I'm looking for the best of both worlds..

Please help, thanks a lot in advance!

Kind regards, Pieter

1

By default, with information from Wikipedia, you get "dead" '
All "dead" modificators are red-painted here.
To get "usual" ' as ' a you need to press Right Alt+' then a

0

This is no solution to your specific problem, which is indeed very strange. But if you are willing to accept a workaround, take a look at this AutoHotkey script which - I think - does just want you want, without the need to use the dead keys layout.

0

The classic Macintosh had a very nice keyboard layout which used Option+Accent keys as dead keys, and used the accent keys themselves as a means of simply typing the characters directly. I would suggest perhaps using a keyboard layout editor to change all the dead keys likewise.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.