1

I have an ASUS laptop (model u56e, windows 7 64-bit) that is baffling me right now. I was recently on a trip, laptop working fine, though partitioned SATA HDD a bit overloaded with vacay pics. On way home, closed laptop, put it in bag & didn't open it for 2 days. When I did, it was dead - POST sound audible, but stuck in loop on ASUS mobo splash screen. Could not enter BIOS.

What I have tried so far:

  1. Removed HDD. Booted into BIOS fine.
  2. Booted into Ubuntu using LiveCD.
  3. Connected HDD with SATA/USB cable. Drive recognized. Backed up important files. Could not mount OS partition, just data partition. Gave me "Windows is hibernated, refused to mount" error.
  4. Successfully mounted OS partition (via USB) using remove_hiberfile command.
  5. Reinstalled HDD. Still stuck on splash screen. Could not enter BIOS. Unable to see if HDD is recognized in BIOS & obviously unable to change boot order. BIOS did recognize USB if I plugged in flash drive.
  6. Removed/reset CMOS battery. No change.
  7. Disassembled laptop & examined motherboard. Board & all connectors appear visually fine.
  8. Checked memory with memtest86. All good.
  9. Confirmed I have latest BIOS version. Reset BIOS defaults. No change.
  10. Repaired MBR using Ubuntu boot-repair. No change.
  11. Installed into desktop. HDD recognized in BIOS. Ran chkdsk. Several errors repaired. No bad sectors. Booted into Windows. A few updates. Rebooted. A few more Windows updates. Rebooted. HDD worked perfectly in desktop (yay!!!)
  12. Reinstalled into laptop. Stuck on ASUS splash screen again. Could not enter BIOS.
  13. Removed & attached HDD via USB. No change. If I connect HDD via USB while inside BIOS, laptop freezes.
  14. Unplugged drive. Still able to enter BIOS & boot from LiveCD with HDD removed.
  15. Attached another SATA drive to laptop via USB. Booted into BIOS fine & recognized drive (had to connect via USB vs. mobo because it was a 3.5" instead of 2.5").

It was suggested that I try to boot HDD via Ubuntu Grub, but I can't because in order to boot into LiveCD, I must have HDD disconnected. If I reconnect before Ubuntu boot is complete, laptop freezes.

Observations:

  • HDD appears healthy. Spins up, no strange noises, able to access/transfer files, etc. Chkdsk revealed no bad sectors.
  • Drive connectors appear healthy. Connects fine in desktop & via USB from within Ubuntu for file transfer.
  • MBR & Windows installation appear healthy. Boots into Windows perfectly while in desktop.
  • RAM checks out as healthy.
  • Motherboard and connections appear visually ok.

I'm at a loss for what to do next. My questions are:

  1. If the motherboard itself is bad, why does a replacement drive boot up?
  2. If the HDD is bad, why does it work perfectly installed in a desktop?
  3. If the motherboard connector is bad, wouldn't the BIOS just not recognize the drive & move on to boot from CD? And why would same problem occur when the HDD is connected via USB?
  4. Obviously there is some problem with this specific HDD interacting with this specific ASUS motherboard. Any ideas what it could be and why it appeared out-of-the-blue?

Can't comment, so edited to add:

Have since run Hitachi disk check WINDFT - no errors on short or extended test, SMART info check out fine, formatted & reinstalled Windows 7 64-bit, rebuilt MBR, re-flashed original (latest) BIOS.

Still hangs on ASUS splash screen after POST sound.

Substitute drive (Toshiba) boots flawlessly into windows from laptop.

Original drive (Hitachi Travelstar 5K750) boots flawlessly into Win7 from desktop, fully accessible from USB in laptop.

Is it possible that the drive is just not getting enough power to spin up when installed internally?

If so, what would cause this & how to fix?

Thanks so much for any advice. This is driving me crazy!!!

  • I would argue that chkdisk doesn't detect errors on healthy systems but hdds can have soft failures so I won't make a big deal about your dismisal of those errors. – Ramhound Jun 27 '14 at 15:42
  • You should definitely get a 2.5" drive that is known to work and attach it to mobo. If it causes problems too, then your mobo is the problem. If not, well, backup everything and give reformat a shot (you'd have to recreate the partition table, to be sure). – arielnmz Jun 27 '14 at 15:55
  • Getting another 2.5" was my next step. Wish I had one here. I'm not completely against reformatting, it's just that before I did I was hoping for some definite sign as to what was wrong. Hate to wipe HDD if the mobo is the problem, you know? Unfortunately, every solution I try just leads to more questions. :/ – Eileen Jun 27 '14 at 15:59
  • OK. Installed another 2.5" into motherboard. Booted into Windows flawlessly. So now I know: HDD + desktop = good (HDD ok). Alternate HDD + laptop = good (mobo ok). Something in interaction between ASUS mobo & original HDD causing problem..... I'm at a loss.... – Eileen Jun 28 '14 at 3:40
  • If you have lost control of one of your accounts then go to this help page and follow the instructions there. This should help you regain control of the question. – Mokubai Jul 3 '14 at 18:34
-1

My Asus laptop was stuck on logo with no way to enter bios. Here's how it got fixed. The thing is to power it on and then remove any battery and unplug the charger to let the laptop turn off by not having any power. Do not turn it off via power button. Then just place battery back and Windows and bios were working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.