9

I've installed the Roboto typeface on my system but it turns out that the default, regular face is rendered as black, even though in the thumbnail it appears to be lighter. This happens on all applications, on Linux and Windows too. Here's an example:

This is how the thumbnails look on any file manager on Linux, the fonts seem fine (Windows doesn't even list the regular face on the collection). Windows only lists the normal face if I remove the black face:

Roboto-Regular.ttf font thumbnail black face thumbnail Windows Black face thumbnail Roboto normal face thumb on windows

And this is how it looks once it's rendered, no matter on what application:

Roboto Regular face sample Black face sample

windows normal face sample Windows black face sample

Any application that asks for the Roboto font, renders its black face instead. Google Chrome on Windows and Linux, side by side, for example:

Google Chrome on Windows Google Chrome on Linux

I've tried removing the black face and symlinking to the regular one with the black's filename, and it works (Windows and Linux result, side by side):

Face removed linux face removed windows

But I lose my black face and the italics are still rendered with the black face, so I'd have to remove the face along with its variants. What can I do? Is symlinking removing my fonts the only solution?

Update:

The problem is that both variants of the font (regular and black) interfere with each other, and I can only have one of the two installed at a time. Is there some sort of font metadata that I could change to fix this?

4

It looks like Google finally updated the Roboto font files on their website for download. You can grab the font here: http://www.google.com/fonts/specimen/Roboto

0

Try the Windows naming:

  • Regular: roboto.ttf
  • Italic: robotoi.ttf
  • Bold: robotob.ttf or robotobd.ttf
  • Bold Italic: robotobi.ttf or robotoz.ttf
  • Black: robotobk.ttf

Keep only these files. Remove the others and try again. I had a similar issue on Linux with ttf-mscorefonts (arial.ttf) and this solved the problem.

  • I've changed their names and they work fine except that now the black font is rendered as the regular one. – arielnmz Jun 27 '14 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.