1

This keyboard has been working fine yesterday. Today I start the computer and it stops working somewhere during the Windows logo animation (I keep toggling the Fn key to check). It doesn't react to keys at all, but if an LED is on when it dies it stays on. The keyboard works fine in the BIOS. I don't recall changing anything in the BIOS. I didn't install any updates.

The keyboard is still recognized in Windows in the Device Manager. It's listed as "Standard PS/2 Keyboard". In the properties it claims "This device is working properly." I have tried to uninstall it there, rebooted twice, but it still doesn't work.

Edit: Tried to restart with the keyboard plugged out, then restart again plugged in. The computer is always turned off completely over night, as I turn off the switch on the multi-outlet.

I tried F8, Boot logging, and the ntbtlog.txt says Loaded driver \SystemRoot\system32\drivers\i8042prt.sys.

I tried booting from the Windows CD, and even there the keyboard is not working.

Edit 2: Ok, now it's getting weird. I boot from some Linuxy rescue CD. It gives me a couple options, I select Boot Manager (PS/2 keyboard is working here). I select the active partition, boot from it. Guess what, the keyboard is now working in Windows. Great! I restart, booting normally. Aaaand: Not working! Boot again with the rescue disk, now it's working again. So, yeah. I'm typing this in Windows on the "broken" keyboard. Do I have to boot from this disk from now on? What is so magical about this boot sequence?

Edit 3: Maybe another clue: When I boot normally, the keyboard is working at the beginning of the boot sequence. Then all 3 LEDs light up for half a sec, then the keyboard stops working. When I boot using the rescue CD boot manager, it's the other way around: The keyboard stops working as soon as I hit enter in the boot manager and the Windows logo pops up. Then, during the Windows logo animation, the keyboard starts working again.

  • Remember you said what can I try :-) So here is what I would try after having done what you did. shut-down the computer, turn the power completly off, meaning pull the wall plug or switch off the PSU. Remove the keyboard from the PS2 slot. Leave it out. power up the computer with it out. Power down completely again, and remove all power from the computer, put the keyboard back, and continue. Why all the stupid stuff? because standby power keeps power on the keyboard, even in the "off" state of the computer. Try , go into the bios and switch the NumLock option, one way or another. – Psycogeek Jun 27 '14 at 22:55
  • If this full shutdown reset thing doesnt fix it, then I (myself) might begin to suspect that there is some software involved, boot into a safe mode, try another bootable disk or something that does not boot into that same system. – Psycogeek Jun 27 '14 at 22:59
  • @Psycogeek Um, yea. I don't even know what to say. See my edit. Thank you for your help so far, seems like we're getting somewhere. – Andreas Haferburg Jun 28 '14 at 7:40
  • There is going to be an eureka moment eventually from somebody. Booting off the linux then passing the boot to the windows OS could skip something Right? It could skip seeing some aspects of the disk structure? Like a crappy rootkit that tries to keylog and breaks stuff? What else in software or hardware is different about using that method? – Psycogeek Jun 28 '14 at 8:45
  • @Psycogeek I scanned with GMER but it couldn't find anything. – Andreas Haferburg Jun 28 '14 at 9:25
3

Exact same problem after I migrated a disk to ssd with a Linux boot CD at my workshop, I was using a USB keyboard.

Tested it before bring back and then the clients ps5 keyboard wouldn't work.

Tried the above registry edit, changed start from 3 to 1 and rebooted, still wouldn't work. Changed it back and then shutdown with the commandline

shutdown /s /t 0

Started up and the keyboard works. Why? Well Windows 10 in an attempt to start quicker suspends a lot of system state so once I booted in my workshop without ps2 that state was maintained after I used the point and click shutdown. The above command line will cause a full and proper shutdown forcing windows to start properly and load disks and drivers properly instead of resuming from suspended disk states

| improve this answer | |
2

In case others have the same problem, here is a solution:

a) regedit

  • Run %Systemroot%\regedit.exe (%Systemroot% is usually C:\Windows\)
  • set the Start REG_DWORD to value of 1 in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt folder.
  • reboot

b) command line

  • Or run this from elevated command line: reg add HKLM\SYSTEM\CurrentControlSet\Services\i8042prt /v Start /d 1 /t REG_DWORD /f
  • reboot

Details

The i8042prt service is responsible the PS/2-style keyboard and mouse devices. The 1 (hex) value means the driver is loaded at kernel initialization.

| improve this answer | |
  • People may be reluctant to muddle in the registry without understanding what they're changing. Can you add a sentence or two to describe what that setting is? Thanks. – fixer1234 Dec 2 '15 at 21:32
  • The i8042prt service is responsible the PS/2-style keyboard and mouse devices. The 1 (hex) value means the driver is loaded at kernel initialization. – SlAy3r Dec 2 '15 at 21:59
0

Just google and install this driver > ID1HTK05WW5 It's a Lenovo software supporting PS-2 devices, seems to be working on all brands.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.