1

I use gnus for my email. Every once in a while, I receive an encrypted email; when I answer "yes" to Gnus offer to decrypt it, it responds smime-verify-region: No CA configured. Now, my workplace doesn't allow any OpenSSL stuff, so I've been hoping to get it working with pgp. But the instructions at http://www.emacswiki.org/emacs/GnusSMIME don't seem fully cogent to me. I've made sure I have gpg installed, and I've added the suggested lines:

;; SMIME in .gnus
(require 'epa-file)
(epa-file-enable)
(setq epg-debug t)

(setq mm-decrypt-option 'always)
(setq mm-verify-option 'always)
(setq gnus-buttonized-mime-types '("multipart/encrypted" "multipart/signed"))
(setq mml-smime-use 'epg)

and I've also added the suggested lines to newly created gpg.conf and gpgsm.conf files (they did not exist previously, although gpg was installed). But I still get the same error when I try to read the encrypted emails. What am I actually supposed to do? How can I decrypt smime in Gnus without openssl?

Note: I do not use BDB (I use org-contacts instead)

GNU Emacs 24.3.1 (x86_64-redhat-linux-gnu, GTK+ Version 3.10.9) of 2014-05-21 on buildvm-07.phx2.fedoraproject.org Gnus v5.13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.