16

My goal is to block the annoying Google "doodles" (i.e. animated soccer-related promos, etc.) that appear in Chrome when a New tab is opened.

Here's what's been tried so far:

(1) Use AdBlock Plus to specifically block the doodle. This actually works very well on the Google.com page itself but as it turns out, opening a New Tab (Cmd-T) doesn't actually load Google.com. It loads some kind of plug-in where AdBlock has no influence.

(2) To which you're probably thinking, "Just change your homepage to Google.com in the Settings". Strangely, this doesn't work. Chrome will hijack the request to Google.com and redirect it to the opaque plug-in described above.

(3) Also tried to be clever by setting my start up page to a more specific URL like "https://www.google.com/search". Same outcome. I even tried using a tinyurl.com redirect for a start up page but this still doesn't work. Chrome still hijacks the request if it knows that the end result is the Google search page.

The only thing that's been remotely helpful is this extension which replaces the New Tab plug-in with a blank page. This is a step in the right direction. The Doodle goes away and I can perform my search from the URL bar. But the ideal scenario would be to make use of the default Google "new tab" page but without the annoying doodles.

Do you know of a clever way to accomplish this?

  • 1
    Although I'm not too well informed of chrome's things, as far as I know the newtab page, along with other builtin pages (like the settings and bookmarks pages) aren't accessible to plugins for security reasons, only by themes and builtin gimmicks of Chrome itself. So I don't think there's an easy way to disable them. – arielnmz Jun 29 '14 at 18:28
  • google.com/ncr = no-country-redirect, leading to way less Doodles (since they are usually country-specific). – Ƭᴇcʜιᴇ007 Jun 29 '14 at 18:48
  • 1
    @techie007: You'd think this would work but it doesn't. Google still hijacks the request and redirects to it's own internal NewTab plug-in which, of course, includes the huge doodle. If it wouldn't hijack the request, I'd be all set; AdBlock would remove the Doodle ASAP from the HTML page. But because hijacks the request and redirect to a plug-in that's immune to AdBlock, I'm stuck. – Chad Decker Jun 29 '14 at 20:19
  • @arielnmz: Yes, unfortunately you are correct. :( – Chad Decker Jun 29 '14 at 20:19
  • I understand doodles are an integral part of Google’s corporate image on the Google Search homepage and the Google Chrome New Tab page. I have nothing against showing them but it should be my election to run them or not (and hog my CPU), taking into account that I open Google search page to search, as its name suggests, not to play. With this aggresive behavior all they get is people scattering or looking for ways to never see again their corporate image (me)... or getting on their users nerves. – cdlvcdlv Feb 22 '18 at 9:26
5

There's a new flag (use-google-local-ntp) that allows disabling New Tab Page service worker and therefore also Google Doodle. Currently it's available in Google Canary 61 so let's hope it lands in stable (soon).

chrome://flags/#use-google-local-ntp

Switch it to "Enabled" and restart Chrome. I wrote about it in this blogpost.

EDIT: It's already available in the stable Chrome 60.

  • It's Jan 2018 (Chrome 63) and I can confirm this method is working. Thanks! – Gaurang Tandon Jan 22 '18 at 10:14
  • 2
    This flags is gone. 76.0.3809.100 I'm forced to see another political Doodle. – Damn Vegetables Aug 14 at 19:31
3

Maybe not a complete solution, but if you go into Settings and change your omnibox search engine to something that's not Google, then the new tab page will only show recently visited pages (no huge Google logo and whatnot). You can still set your homepage to Google for quicker access to searches, but for most of my omnibox searches, Bing works acceptably. If Google wants to play it that way...

  • 2
    This technique works and the Doodle is removed! But then I'm stuck using an inferior search engine. :( Your answer gave me an idea, though. If I click the "manage search engines" button, could I create my own entry that (in)directly points to the Google HTML page and avoids the plugin? Well, it allows you to do this...for any search page EXCEPT Google, including tinyurl redirect pointers. The amount of effort Google engineers put in to forcing people to view their Doodle when using their search engine is absolutely astounding! I am in awe. – Chad Decker Jun 29 '14 at 20:28
  • This is evil! Curse on Google! – Anwar Feb 18 '15 at 10:53
  • @Anwar You know the former Google motto, don't you? – cdlvcdlv Sep 4 '18 at 8:24
3

I tried Chad Decker's idea given in his comment: "If I click the "manage search engines" button, could I create my own entry that (in)directly points to the Google HTML page and avoids the plugin?"

I copied the URL of the default Google search engine to a new name, and made that the default search engine, namely:

{google:baseURL}search?q=%s&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:bookmarkBarPinned}{google:searchClient}{google:sourceId}{google:instantExtendedEnabledParameter}{google:omniboxStartMarginParameter}{google:contextualSearchVersion}ie={inputEncoding}

For me this works (on openSUSE 64bit, latest updates, October 31, 2014). So I don't have to see those ugly Halloween doodles any more. ;-)

  • This is an interesting solution and definitely one worth exploring. Thanks for sharing that. What I ended up doing was installing a Chrome extension called "Empty New Tab Page." Now when I open a new browser window or tab, I'm presented with a totally blank page with the cursor set to the search bar at the top. That, combined with the AdBlockers, allow me to use Google in much cleaner, clutter-free way. I'll never have to deal with those annoying "doodles" again. :) – Chad Decker Oct 31 '14 at 18:12
  • To be clear, my solution above does not "present with a totally blank page", as the extension you suggest; it is just not the Google Doodle that appears, only the name "Google". This is enough for me, but if you want a blank page, the extension you propose is definitely better. – jciloa Oct 31 '14 at 18:58
  • 1
    A Google employee suggested searching from an empty results page: https://www.google.com/search?q=+ It works for me on my phone, where I can't use Adblock etc. It's bizarre how Google's original page was specifically designed to not have any crud like this, and now they go out of their way to force it on us. – endolith Jan 11 '16 at 17:43
  • @endolith I use myself this very solution. I think the page you reference contains the simpler ways to get rid of annoying Google's doodles. You should add it as an answer. – cdlvcdlv Feb 22 '18 at 9:07
  • 1
    @endolith I think Google is making a new move. I was getting recurrent captchas with every search. I connected to VPN and the same thing until I came up with deleting search?q=+ and no more captchas! 😠 – cdlvcdlv Jul 16 '18 at 10:31
0

You can actually block the Doodle animation with AdBlock Chrome's extension (or similiar) like if was an advertisement.

  • Go to the Customize panel of the AdBlock extension
  • Add a new custom filter with this line:

    www.google.com##A#ctDoodleNotifier
    
  • Then save, the Doodle animation will disappear!

If you also want to disable the "Most visited" panel, also add this line:

www.google.com##div#most-visited

Some Notes:

  • If you live outside USA, you should update the google.com domain to the one your country belongs (the AdBlock filter doesn't work apparently with wildcards).
  • This assumes that the Doodle animation is inside an A tag with ID="ctDoodleNotifier"
  • Similiar, the Most visited panel is inside a DIV tag with ID="most-visited"
  • This was tested on Chrome version 43.
  • When Chrome is launched, the New Tab page loads as original. I infer is because the AdBlock plugin is not loaded at that time. Updating the page will work as expected.
0

Since Chrome 73 you have to set to Disabled the next flag:

chrome://flags/#doodles-on-local-ntp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.