8

In Chrome, the protocol is hidden for some reason. This affects copy/paste from the address bar into an email or some other document. For example, let's say I am at this URL:

subdomain.domain.com/myvitualdir/customerprofile.aspx?id=18272

If I just want to copy subdomain.domain.com/myvitualdir/myvitualdir, it won't actually copy the HTTP part.

Update: I just figured out what causes this "quirk" to occur. Let's say you have www.whatever.com/myvd in your browser history. If you start typing whatever in the address bar, Chrome will start auto-completing matching URLs for you. While still in the auto-complete stage (ie, not actually browsing to the URL), attempting to copy the URL will not include the protocol. It seems intermittent, though, because sometimes it copies the protocol and other times it doesn't.

10
  • This is a list of all command line arguments. So far I found none to enable the protocol.
    – Uwe Keim
    Jul 1, 2014 at 12:04
  • 4
    Your Chrome is weird. Even though the protocol is invisible, Chrome has always auto-added it when copying...
    – user1686
    Jul 1, 2014 at 12:18
  • 1
    To copy the protocol part, you have to copy the whole url, not just a part of it. If you need to edit the url, copy/paste the whole thing and edit after you paste it.
    – Jakke
    Jul 1, 2014 at 12:25
  • @grawity As Jakke commented, you have to copy the whole URL and then edit it after you paste it. However, I want to copy only part of the URL (eg, from the middle to the beginning). When you do that, the protocol doesn't copy and it's a bit of an annoyance. Jul 1, 2014 at 12:33
  • Updated my question. Jul 1, 2014 at 12:38

1 Answer 1

3

Currently and unfortunately, the is no way to display the protocol in the address bar in Chrome. You have to use another browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.